PROBLEMA

Conjunto de dados não encontrado ao publicar pesquisas no Portal for ArcGIS

Last Published: April 27, 2022

Descrição

A tentativa de publicar pesquisas do ArcGIS Survey123 Connect ou ArcGIS Survey123 no Portal for ArcGIS retorna as seguintes mensagens de erro:

Erro: Conjunto de dados não encontrado. Status: Erro. Detalhes: código 500
Erro: Erro ao obter parâmetro de resultado. Status: Erro. Detalhes: código 500
Erro: Não é possível criar uma nova pesquisa. ERRO: Conjunto de dados não encontrado.
A mensagem de erro no ArcGIS Survey123

Causa

As mensagens de erro fornecidas indicam um problema mais amplo. As possíveis causas desse erro incluem, mas não estão limitadas a:

  • O Portal for ArcGIS é incapaz de criar camadas de feição hospedadas, uma parte central do processo de publicação.
  • Os serviços de procesamento PublishingTools ou PublishingToolsEx não estão executando ou exigem reiniciar.
  • A licença do ArcGIS Data Store expirou.
  • O ArcGIS Data Store não está validado no ArcGIS Server.
  • O usuário não tem permissões para publicar serviços de feição hospedados no ArcGIS Server.
  • O formulário do Survey123 publicado no Portal for ArcGIS contém apenas uma pergunta de ponto geográfico com a coluna bind :: esri: fieldType personalizada, definida como nula. Consulte BUG-000137465 para mais informações.

Solução ou Solução Provisória

  1. Revise o Portal for ArcGIS para garantir ser capas de publicar camadas de feição hospedadas. Teste isso criando uma camada usando o Portal for ArcGIS, por um modelo ou carregando diretamente um arquivo CSV.
Nota: Se o erro não for retornado para todos os formulários de pesquisa, poderá haver um problema de configuração ou um problema com o design do XLSForm de pesquisa. Publique novamente o formulário de pesquisa ou consulte ArcGIS Survey123: Fundamentos do XLSForm para as melhores práticas de design do XLSForm.
  1. Se o erro persistir, verifique o status dos serviços de geoprocessamento PublishingTools ou PublishingToolsEx. Consulte ArcGIS Server: Iniciar e parar serviços para mais informações.
  2. Marque os logs do ArcGIS Server Manager para identificar a causa subjacente. Consulte ArcGIS Server: Logs do servidor para etapas sobre acesso os logs.
    1. Execute o utilitário describedatastore.bat. Consulte ArcGIS Enterprise: Referência do utilitário de comando do ArcGIS Data Store para mais informações sobre referências do utilitário de comando do ArcGIS Data Store.
    2. Marque o modo Armazenamento de Dados e espaço Livre em disco. Se o modo Armazenamento de Dados estiver definido como READONLY e houver espaço em disco disponível, use o seguinte comando para definir o armazenamento de dados relacional como READWRITE.
changedatastoremode readonly|readwrite [--prompt <yes|no>]
Nota: O modo Armazenamento de Dados é automaticamente definido para READONLY quando o espaço em disco na máquina é baixo, para evitar a perda de dados.
  1. Reinicie o serviço do ArcGIS Data Store no Windows.
A Janela de Comando para describedatastore.bat

ID do Artigo:000022129

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com suporte técnico

Baixe o Esri Support App

Ir para opções de download