PROBLEMA

ArcGIS Pro para de responder após o login

Last Published: September 22, 2020

Descrição

A caixa de diálogo Registro do ArcGIS Pro pára de responder, fazendo com que as tentativas de login falhem, o que pode avisar erros relacionados à certificação, licenciamento ou um nome de usuário inválido.

Causa

A entrada de registro do ArcGIS Pro está corrompida. Isso pode ocorrer quando várias versões do ArcGIS for Desktop são instaladas na mesma máquina e as configurações da variável de ambiente no registro do sistema operacional são modificadas para acomodar este cenário.

Solução ou Solução Provisória

As seguintes soluções alternativas são possíveis soluções para esse problema.
Nota: Antes de começar, verifique se uma licença do ArcGIS Pro ativa está alocada. O seguinte documento de Ajuda do ArcGIS Online descreve como fazer isso: Gerenciar licenças.
Solução Alternativa 1: Renomeie as pastas do ArcGIS Pro
Nota: A pasta AppData é uma pasta oculta. O seguinte documento de Suporte da Microsoft descreve como mostrar arquivos ocultos: Mostrar arquivos ocultos
  1. Navegue até os seguintes caminhos:
    • C:\Users\<computer name>\AppData\Roaming\ESRI, e
    • C:\Users\<computer name>\AppData\Local\ESRI
  2. Renomeie a pasta ArcGISpro para ArcGISpro_old.
Nota: Renomear a pasta ArcGISpro redefine o ArcGIS Pro. Inicie o ArcGIS Pro para recriar a pasta ArcGIS Pro.
  1. Reinicie a máquina do ArcGIS Pro.
  2. Abra o ArcGIS Pro.
  3. Entre no ArcGIS Pro para verificar.
Solução Alternativa 2: Renomear a pasta FLEXnet
Nota: A pasta ProgramData é uma pasta oculta.
  1. Navegue até C:\ProgramData\FLEXnet.
  2. Renomeie a pasta FLEXnet para FLEXnet_old.
Nota: Renomear a pasta FLEXnet reinicia FLEXnet. Inicie o ArcGIS Pro para criar a pasta FLEXnet.
  1. Reinicie a máquina do ArcGIS Pro.
  2. Abra o ArcGIS Pro.
  3. Entre no ArcGIS Pro para verificar.
Solução Alternativa 3: Remover as chaves de registro corrompidas
Aviso: As instruções abaixo incluem fazer alterações em partes fundamentais do seu sistema operacional. É recomendado criar uma cópia de segurança do sistema operacional e dos arquivos, incluindo o registro, antes de continuar. Consulte um profissional de sistemas de computador qualificado, se necessário. A Esri não pode garantir resultados de modificações incorretas ao seguir estas instruções. Portanto, tenha cuidado e proceda por sua conta e risco.
  1. Navegue até Iniciar do Windows, na barra de pesquisa Pesquisar programas e arquivos, digite regedit.
  2. Abra o Editor do Registro com uma conta de administrador.
A imagem mostra o ícone do regedit
  1. Exclua as seguintes subchaves de registro do armazenamento HKEY_CURRENT_USER :
  • HKEY_CURRENT_USER\Software\ESRI\ArcGIS Online for Pro
  • HKEY_CURRENT_USER\Software\ESRI\ArcGISPro
  • HKEY_CURRENT_USER\Software\ESRI\ArcGIS Online
  • HKEY_CURRENT_USER\Software\ESRI\ArcGISPro1.0
  1. Reinicie a máquina do ArcGIS Pro.
  2. Abra o ArcGIS Pro.
  3. Entre no ArcGIS Pro para verificar.

ID do Artigo:000013863

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