PROBLEMA

Ocorreu um erro ao atualizar o ArcGIS Survey123 para a versão 3.12 em um dispositivo Android

Last Published: April 27, 2022

Descrição

O Google Play Store implementou requisitos para melhorar a segurança dos dados usados por aplicativos armazenados em dispositivos. Anteriormente, os aplicativos instalados tinham acesso ao armazenamento 'público' e ao armazenamento 'privado' específico do aplicativo no dispositivo. Em termos de desenvolvedor Android, eles são chamados de armazenamento 'externo' e 'com escopo', respectivamente. Os aplicativos agora precisam armazenar todos os dados no armazenamento com escopo definido (privado).

A versão 3.12 do ArcGIS Survey123 inclui um processo de migração automática que começa quando o aplicativo é aberto pela primeira vez. Este processo migra dados 3.11 originais, incluindo pesquisas e configurações do usuário, para o armazenamento com escopo definido. Em alguns casos, a migração falha e um código de erro é retornado.

Causa

Há vários motivos pelos quais a migração de armazenamento do Android falha. Consulte a lista de códigos de erro e suas descrições abaixo.

Solução ou Solução Provisória

Para cada código de erro, consulte as etapas de resolução na tabela abaixo.

Como parte do processo de migração, o Survey123 grava um arquivo de log denominado ‘migration.log’ na pasta ArcGIS original no dispositivo Android (normalmente encontrado em /Internal storage/ArcGIS, /sdcard/ArcGIS, /storage/emulated/0/ArcGIS, ou semelhante).

Nota: Se o problema não for resolvido usando as etapas de resolução, guarde uma cópia do arquivo de log e entre em contato com o Esri Support Service para obter mais assistência.
CódigoDescriçãoEtapas de Resolução
2900Exceção de aplicativo devido a erro desconhecidoForneça uma cópia do arquivo de log e entre em contato com o Suporte da Esri para obter mais ajuda.
2901Permissão de acesso ao armazenamento rejeitada. O usuário negou ao aplicativo o acesso ao dispositivo de armazenamento.Reinicie o aplicativo. Um diálogo aparece solicitando permissão para acessar o dispositivo de armazenamento. A permissão deve ser concedida para que a migração prossiga.
2902Pasta de dados ArcGIS não encontrada no armazenamento validadoConsulte a mensagem de erro no arquivo de log para obter o caminho esperado para a pasta ArcGIS validada. Confirme se esta pasta existe neste local.
2903Falha na verificação, pois o arquivo não existe no local de destinoConsulte a mensagem de erro no arquivo de log para o arquivo esperado não encontrado no novo local de armazenamento.
2904Falha na verificação, pois os tamanhos dos arquivos não são iguaisConsulte a mensagem de erro no arquivo de log para o arquivo que não tem o mesmo tamanho no local de armazenamento antigo e no novo.
2905O dispositivo de armazenamento não tem espaço livre suficienteConsulte a mensagem de erro no arquivo de log para o espaço total do dispositivo de armazenamento, o espaço livre disponível e o tamanho das pastas ArcGIS que devem ser copiadas para a migração. O espaço mínimo necessário é duas vezes o tamanho da pasta ArcGIS. Libere o armazenamento manualmente no dispositivo para permitir que ocorra a migração.
2906Falha ao remover o arquivo de configurações validadoCertifique-se que nenhuma outra instância do Survey123 esteja aberta e que nenhum outro aplicativo tenha aberto arquivos ou pastas no local de armazenamento validado do ArcGIS. Execute a migração novamente.
2907Falha ao criar pasta no local de destinoReinicie o aplicativo. Um diálogo aparecerá solicitando permissão para acessar o dispositivo de armazenamento. A permissão deve ser concedida para que a migração prossiga.
2908Falha ao remover arquivo zip existenteCertifique-se que nenhuma outra instância do Survey123 esteja aberta e que nenhum outro aplicativo tenha aberto arquivos ou pastas no local de armazenamento validado do ArcGIS. Execute a migração novamente.
2909Falha ao remover pasta de armazenamento validadaCertifique-se que nenhuma outra instância do Survey123 esteja aberta e que nenhum outro aplicativo tenha aberto arquivos ou pastas no local de armazenamento validado do ArcGIS. Execute a migração novamente.
2910O banco de dados não existe no armazenamento com escopo definido após a migração do arquivoConfirme se o arquivo do banco de dados de pesquisa existe no local de armazenamento validado antes do processo de migração.
2911Falha ao atualizar os caminhos da biblioteca de mapas no arquivo de configuraçõesCertifique-se que o arquivo de configurações exista no local de armazenamento com escopo definido e que nenhum outro aplicativo tenha o arquivo aberto. Execute a migração novamente.
2912Falha ao copiar o arquivo de dados para o armazenamento com escopo defnidoReinicie o aplicativo. Um diálogo aparecerá solicitando permissão para acessar o dispositivo de armazenamento. A permissão deve ser concedida para que a migração prossiga.
2913Falha ao copiar o arquivo de dados sobre um arquivo existente no armazenamento com escopo definidoCertifique-se que nenhuma outra instância do Survey123 esteja aberta e que nenhum outro aplicativo tenha aberto arquivos ou pastas no local de armazenamento com escopo definido. Execute a migração novamente.
2914Falha ao abrir o arquivo de configurações para atualizaçãoCertifique-se que o arquivo de configurações exista no local de armazenamento com escopo definido e que nenhum outro aplicativo tenha o arquivo aberto. Execute a migração novamente.
2915Falha ao atualizar caminhos de dispositivos conhecidosCertifique-se que o arquivo de configurações exista no local de armazenamento com escopo definido e que nenhum outro aplicativo tenha o arquivo aberto. Execute a migração novamente.
2917Falha ao adicionar arquivo no arquivo zipExecute a migração novamente.
2918Falha ao abrir arquvivo de log para gravaçãoConfirme se o local de armazenamento de dados validado existe.
2919O arquivo de configurações não existe no armazenamento com escopo definido após a migração do arquivoConfirme se o arquivo de configurações do Survey123 existe no local de armazenamento validado.
2920Falha ao ler do armazenamento com escopo definido durante o teste de comprovaçãoConfirme se o local de armazenamento com escopo definido esperado existe.
2921Falha ao gravar no armazenamento com escopo definido durante o teste de comprovaçãoConfirme se o local de armazenamento com escopo definido esperado existe.
2922Falha ao gravar no armazenamento com escopo definido durante o teste de comprovaçãoConfirme se o local de armazenamento com escopo definido esperado existe.
2923Falha ao gravar no armazenamento com escopo definido durante o teste de comprovaçãoConfirme se o local de armazenamento com escopo definido esperado existe.
2924Falha ao gravar no armazenamento com escopo definido durante o teste de comprovaçãoConfirme se o local de armazenamento com escopo definido esperado existe.
2925Falha ao gravar no armazenamento com escopo definido durante o teste de comprovaçãoConfirme se o local de armazenamento com escopo definido esperado existe.
2926Falha ao gravar arquivo zipExecute a migração novamente.

ID do Artigo: 000025129

Receba notificações e encontre soluções para problemas novos ou comuns

Obtenha respostas resumidas e soluções de vídeo do nosso novo chatbot de IA.

Baixe o Aplicativo de Suporte da Esri

Informações Relacionadas

Descubra mais sobre este tema

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com Suporte Técnico

Baixe o Aplicativo de Suporte da Esri

Ir para as opções de download