PROBLEMA

novos Agentes do Monitor não podem ser adicionados após atualizar para ArcGIS Monitor 2023.3.1

Last Published: January 20, 2025

Descrição

Após atualizar para ArcGIS Monitor 2023.3.1, novos Agentes não podem ser adicionados com o seguinte erro:

"Failed to fetch".

imagem do erro ao conectar-se ao Monitor Server

Causa

 

Ao inspecionar o tráfego de rede, um erro de 'solicitação de origem cruzada bloqueada' (CORS) é retornado, conforme mostrado na imagem a seguir:

image001.png

Com o erro de CORS, observamos que a solicitação da máquina do Agente para a máquina do Servidor para obter um token é bloqueada, e o registro falha devido a um erro de rede.

Solução ou Solução Provisória

Abrir a URL de administração do site do Monitor na máquina do Agente e simplesmente efetuar o login permitiu que o novo Agent continuasse o processo de registro em outra guia do navegador.

  1. Na máquina do Agente, abra uma nova guia no navegador e navegue até a página Administração do site do Monitor Server.
  2. Efetue o login no site do Monitor Server.
  3. Volte para a guia para registrar o Agente e clique no botão Avançar sem o erro "Falha ao buscar".

ID do Artigo: 000032368

Obtenha suporte com IA

Resolva seu problema rapidamente com o chatbot de IA de suporte da Esri.

Comece a conversar agora

Descubra mais sobre este tema

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com Suporte Técnico

Comece a conversar agora

Ir para as opções de download