Instrução

Não foi possível entrar utilizando Idp no ArcGIS Enterprise. O IDP suporta Asserção SAML Criptografada, mas envia Asserção não criptografada

Last Published: August 24, 2024

Descrição

Ao tentar entrar no ArcGIS Enterprise com Security Assertion Markup Language (SAML), o seguinte erro é retornado:

Error:   
Unable to login using Idp. IDP supports Encrypted SAML Assertion, but sends unencrypted Assertion
A mensagem de erro "Não foi possível entrar usando Idp. O IDP suporta Asserção SAML Criptografada, mas Asserção não criptografada enviada." é retornado

Causa

  • A opção Codificar Asserção está habilitada no Portal for ArcGIS.
  • O certificado samlcert não é importado no portal do provedor de identidade (IDP).

Solução ou Solução Provisória

Desabilitar a opção Codificar Asserção

  1. Entre no Portal for ArcGIS e clique em Organização > Configurações > Segurança.
  2. Na seção Logons , selecione o IDP.
  3. Na página Especificar propriedades , expanda Mostrar configurações avançadas.
  4. Desabilite a opção Codificar Asserção .
  5. Clique em Salvar.

Importar o certificado samlcert no portal do IDP

Note: 
The following workaround may require the assistance of the organization's IT team.
  1. Desabilite a opção Codificar Asserção.
    1. Entre no Portal for ArcGIS e clique em Organização > Configurações > Segurança.
    2. Na seção Logins , selecione o provedor de identidade.
    3. Na página Especificar propriedades , expanda Mostrar configurações avançadas.
    4. Desabilite a opção Codificar Asserção .
    5. Clique em Salvar.
  2. Exporte o certificado samlcert.
    1. Entre no ArcGIS Portal Administrator Directory .
    2. Clique em Segurança > SSLCertificates.
    3. Clique no certificado samlcert existente.
    4. Clique em Exportar.
  3. Importe o certificado samlcert no portal do IDP e localize as configurações de criptografia do token.
  4. Ative o certificado samlcert assim que ele for importado.
  5. Habilite a opção Codificar Asserção.
    1. Entre no Portal for ArcGIS e clique em Organização > Configurações > Segurança.
    2. Na seção Logins , selecione o IDP.
    3. Na página Especificar propriedades , expanda Mostrar configurações avançadas.
    4. Habilite a opção Codificar Asserção.
    5. Clique em Salvar.
  6. Limpe o cache do navegador e entre novamente usando o login de SAML.

ID do Artigo: 000031784

Obtenha suporte com IA

Resolva seu problema rapidamente com o chatbot de IA de suporte da Esri.

Comece a conversar agora

Informações Relacionadas

Descubra mais sobre este tema

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com Suporte Técnico

Comece a conversar agora

Ir para as opções de download