ERRO

Falha ao carregar as ferramentas do sistema

Last Published: December 29, 2020

Mensagem de Erro

No ArcGIS Pro, a tentativa de abrir o painel de Geoprocessamento retorna o seguinte erro:

Erro: Falha ao carregar as ferramentas do sistema

Em alguns casos, o erro é seguido por um erro de rastreamento do Python referindo-se a um módulo que não pode ser importado, conforme mostrado na imagem abaixo.

Imagem de erro de rastreamento do Python

Causa

O erro está relacionado ao ambiente de projeto Python que o ArcGIS Pro está usando. Isso pode ser causado por uma incompatibilidade no arquivo proenv.txt, um cache completo ou uma instalação corrompida do ArcGIS Pro.

Solução ou Solução Provisória

Esse erro pode ser resolvido executando qualquer uma das soluções listadas abaixo, modificando o arquivo proenv.txt ou limpando os arquivos em cache. Se o problema persistir, prossiga com a solução subsequente, reinstalando o ArcGIS Pro.

Modifique o arquivo proenv.txt para corresponder ao ambiente especificado no ArcGIS Pro

  1. No ArcGIS Pro, vá até Configurações > Python.
  2. Anote o ambiente do projeto ativo. Neste exemplo, o ambiente ativo no ArcGIS Pro é arcgispro-py3.
Imagem mostrando o ambiente do projeto Python no ArcGIS Pro.
  1. Vá até o seguinte local da pasta:
C:\Program Files\ArcGIS\Pro\bin\Python\Scripts
  1. Abra o arquivo proenv.txt em um editor de texto.
  2. Verifique se o ambiente ativo no ArcGIS Pro corresponde ao ambiente listado neste arquivo de texto. Se o ambiente for diferente, modifique o arquivo de texto para corresponder ao ambiente ativo no ArcGIS Pro.
  3. Salve e feche o arquivo proenv.txt.
Imagem mostrando o arquivo de texto proenv.
  1. Reinicie o ArcGIS Pro.

Limpar cache
Limpe todos os arquivos de cache na pasta AppData e reinicie o ArcGIS Pro.

C:\Users\\AppData\Local\ESRI\Local Caches
Nota: A pasta AppData é uma pasta oculta. Para exibir pastas ocultas, consulte Suporte do Microsoft Windows: Mostrar arquivos ocultos.

Reinstalar o ArcGIS Pro

Aviso: As instruções abaixo incluem fazer alterações em partes essenciais do sistema operacional. A Esri recomenda fazer uma cópia de segurança do sistema operacional e dos arquivos, incluindo o registro, antes de continuar. A Esri não pode garantir resultados de modificações incorretas ao seguir estas instruções. Precaução no exercício. Consulte um profissional de sistemas de computador qualificado, se necessário.

Execute uma desinstalação limpa consultando Esri Belux: Desinstalação limpa do ArcGIS Pro. Após realizar uma desinstalação limpa, reinstale o ArcGIS Pro seguindo as instruções no ArcGIS Pro: Instalar o ArcGIS Pro.

ID do Artigo: 000022262

Receba notificações e encontre soluções para problemas novos ou comuns

Obtenha respostas resumidas e soluções de vídeo do nosso novo chatbot de IA.

Baixe o Aplicativo de Suporte da Esri

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com Suporte Técnico

Baixe o Aplicativo de Suporte da Esri

Ir para as opções de download