Instrução

Falha ao criar conexão cxn-<number>java.netConnectException

Last Published: January 26, 2024

Descrição

O ArcGIS GeoEvent Server pode utilizar o serviço da plataforma RabbitMQ para operar e, em alguns casos, as tentativas de implantar o ArcGIS GeoEvent Server na plataforma falham e retornam o seguinte erro:

Error:
Failed to create connection cxn-<number> java.netConnectException

Causa

Os possíveis cenários em que o erro pode ser retornado incluem:

  • Atualizando o ArcGIS GeoEvent Server de uma versão mais antiga para a versão 10.6 em diante.
  • Instalando uma nova versão do ArcGIS GeoEvent Server versão 10.6 ou 10.6.1.
  • Alterando a conta de serviço do Windows executando ArcGIS GeoEvent Server.

Há problemas conhecidos entre a plataforma RabbitMQ e o ArcGIS GeoEvent Server, incluindo o erro de rabbitmq.net cxn.** genérico.

  • O ArcGIS GeoEvent Server inicia antes do início dos processos do ArcSOC for ArcGIS Server.
  • O arquivo rabbitmq.conf está ausente na pasta ROAMING do Windows.

Solução ou Solução Provisória

Para implantar com sucesso o ArcGIS GeoEvent Server, certifique-se de que os processos do ArcSOC estejam em execução no Gerenciador de Tarefas do Windows. Se o arquivo rabbitmq.conf estiver ausente, conclua as seguintes etapas para resolver o problema:

  1. Certifique-se de que o serviço da plataforma esteja em execução no endpoint de administração do ArcGIS Server:
https://machine.dom/server/admin/system/platformservices
  1. Pare os serviços do ArcGIS Server, ArcGIS GeoEvent gateway e GeoEvent Server Windows. Consulte ArcGIS Server: Iniciar e parar serviços para etapas sobre fazer isto.
  1. Navegue até a seguinte pasta e verifique se o arquivo rabbitmq.conf está presente:
C:/Users/<run-as user>/AppData/Roaming/RabbitMQ
Note:
The AppData folder is a hidden folder.
  1. Se o arquivo rabbitmq.conf estiver ausente na Etapa 3, navegue até o seguinte local de pasta e copie o arquivo rabbitmq.conf:
C:\Program Files\ArcGIS\Server\framework\runtime\rabbitmq\etc\RabbitMQ
  1. Cole o arquivo de configuração na pasta mencionada na Etapa 3.
  2. Reinicie a implantação.

ID do Artigo: 000021959

Receba notificações e encontre soluções para problemas novos ou comuns

Obtenha respostas resumidas e soluções de vídeo do nosso novo chatbot de IA.

Baixe o Aplicativo de Suporte da Esri

Informações Relacionadas

Descubra mais sobre este tema

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com Suporte Técnico

Baixe o Aplicativo de Suporte da Esri

Ir para as opções de download