ERRO

Não foi possível encontrar uma licença principal

Last Published: March 23, 2021

Mensagem de Erro

Ao iniciar o ArcGIS Pro e entrar usando credenciais enterprise, a seguinte mensagem de erro é retornada:

Erro: Não foi possível encontrar uma licença principal. Selecione outra opção de licenciamento ou entre em contato com o administrador para atualizar suas licenças.

Causa

Este problema tem duas causas potenciais:

  • O arquivo de autorização JSON do usuário nomeado é autorizado no ArcGIS Enterprise, mas não é autorizado no ArcGIS License Manager.
  • O ArcGIS Pro retém informações de licenciamento antigas/corrompidas após uma atualização que deve ser apagada.

Solução ou Solução Provisória

Execute as etapas a seguir para resolver o problema:

Problema 1: O arquivo de autorização JSON do usuário nomeado é autorizado no ArcGIS Enterprise, mas não é autorizado no ArcGIS License Manager.

  1. Inicie o ArcGIS License Server Administrator.
  2. Selecione Autorização no painel esquerdo.
  3. No menu suspenso Versão, selecione Usuário Nomeado e clique em Autorizar Agora.
  1. Selecione a opção de autorização: Recebi um arquivo de autorização e agora estou pronto para concluir o processo de autorização.
  2. Clique em Procurar e vá até o arquivo de autorização JSON usado com ArcGIS Enterprise. Clique em Avançar.
  1. Uma caixa de diálogo é exibida, indicando que as licenças de usuário nomeadas foram aplicadas. Clique em OK.
  1. Clique em OK para fechar o ArcGIS License Server Administrator.

Problema 2: O ArcGIS Pro retém informações de licenciamento antigas/corrompidas após uma atualização que deve ser apagada.

Aviso: As instruções abaixo incluem fazer alterações em partes essenciais do seu sistema operacional. É recomendável criar uma cópia de segurança do sistema operacional e dos arquivos, incluindo o registro, antes de continuar. Consulte um profissional qualificado de sistemas de computador, se necessário. A Esri não pode garantir resultados de modificações incorretas ao seguir estas instruções. Então, tenha cuidado e prossiga por sua conta e risco. Este processo redefine o ArcGIS Pro para suas configurações padrão. Quaisquer personalizações ou preferências (não os dados do projeto) serão perdidas.
  1. Feche o ArcGIS Pro.
  2. Navegue até: C:\Users\<local profile>\AppData\Local\ESRI_Licensing
  3. Renomeie ESRI_Licensing para ESRI_Licensing_old.
  4. Abra o Editor do Registro e vá até HKEY_CURRENT_USER\Software e renomeie o hive ESRI para ESRI_old
  5. Abra novamente o ArcGIS Pro e tente consumir uma licença de Usuário Nomeado.

ID do Artigo:000022898

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com suporte técnico

Baixe o Esri Support App

Ir para opções de download

Informações Relacionadas

Descubra mais sobre este tema