PROBLEMA

ArcGlobe para de responder em "Gerando Módulo ArcID" e não abre

Last Published: December 1, 2020

Descrição

Após instalar o ArcGIS Desktop, o ArcGlobe às vezes para de responder na mensagem "Gerando Módulo ArcID". O Gerenciador de Tarefas revela que ArcGlobe.exe está sendo executado e consumindo tempo do processador, mas o aplicativo não abre.

Nota: Este artigo se refere ao ArcGIS Server versões 10.0 e anteriores apenas. Versões posteriores do ArcGIS podem conter diferentes funcionalidades, bem como diferentes nomes e locais para menus, comandos e ferramentas de geoprocessamento.

Causa

Em máquinas com vários núcleos de processador, um ou mais dos núcleos podem estar operando na capacidade máxima, enquanto o outro não. Nesses casos, se a carga de trabalho do processador não puder ser redistribuída, o ArcGlobe não abrirá completamente. Encerrar o processo do ArcGlobe.exe não faz com que a carga de trabalho do processador seja redistribuída automaticamente de maneira adequada.

Aviso: As instruções a seguir envolvem a modificação de componentes críticos de seu sistema operacional. É recomendável fazer backup do sistema operacional e dos arquivos, incluindo o registro, antes de continuar. Consulte um profissional de sistemas de computador qualificado, se necessário. A ESRI não pode garantir os resultados de modificações incorretas ao seguir estas instruções. Portanto, tenha cuidado e proceda por sua conta e risco.

Solução ou Solução Provisória

Para solucionar esse problema, siga as etapas abaixo para desabilitar e reabilitar o suporte a vários processadores.

Para Windows 2000, Windows XP e Windows 2003:

  1. Edite o arquivo boot.ini na máquina para desabilitar o suporte a vários processadores.
  2. Clique com o botão direito em Meu computador e selecione Propriedades.
  3. Na janela Propriedades, clique na guia Avançado.
  4. Na área Inicialização e recuperação, clique no botão Configurações.
  5. Ao lado do rótulo Para editar o arquivo de opções de inicialização manualmente, clique em Editar e pressione Editar.
  6. No arquivo Boot.ini, adicione a opção /numproc=1 depois da opção /fastdetect. Clique em Arquivo > Salvar. Feche o arquivo Boot.ini.
  7. Reinicie a máquina. Após a reinicialização da máquina, abra o ArcGlobe. Deve abrir sem problemas.
  8. Depois que o ArcGlobe for aberto com sucesso, feche o aplicativo. Siga as etapas 1-3 acima e remova a opção /numproc=1 depois da opção /fastdetect e salve a alteração.
  9. Reinicialize a máquina novamente. O ArcGlobe agora deve abrir e funcionar corretamente sem mais problemas.

No Windows Vista e no Windows Server 2008, não há um arquivo boot.ini. Em vez disso, o número de processadores disponíveis na inicialização do sistema pode ser definido nas Opções de inicialização avançadas na ferramenta Configuração do Sistema do Windows.

  1. Na área de trabalho do Windows, pressione o botão Iniciar e selecione EXECUTAR.
  2. Na caixa EXECUTAR, digite MSCONFIG e pressione [enter].
  3. A ferramenta Configuração do Sistema do Windows é aberta. Na ferramenta Configuração do Sistema, selecione a guia Boot e clique no botão Opções Avançadas.
  4. Na caixa de diálogo Opções Avançadas de Inicialização, marque a caixa ao lado de Número de Processadores para ativar o menu suspenso do número do processador e selecione 1 como o número de processadores disponíveis.
  5. Reinicie a máquina. O ArcGlobe agora deve abrir e funcionar corretamente sem mais problemas.
  6. Depois que o ArcGlobe for aberto com sucesso, feche o aplicativo. Siga as etapas 8 a 10 da seção anterior, mas altere o número de processadores disponíveis de volta ao valor original.
  7. Reinicialize a máquina novamente. O ArcGlobe agora deve abrir e funcionar corretamente sem mais problemas.

ID do Artigo:000010286

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com suporte técnico

Baixe o Esri Support App

Ir para opções de download

Descubra mais sobre este tema