Instrução

os logs do ArcGIS Server relatam mensagens graves a cada hora, indicando falha na inicialização do processador webhook

Last Published: October 25, 2024

Descrição

Note:
This issue was fixed in ArcGIS Enterprise 11.3.

Após atualizar o ArcGIS Enterprise da 11.0 ou 11.1 para a versão 11.2, são observadas mensagens de log graves do ArcGIS Server uma vez por hora, sobre o processador do webhook falhando ao inicializar ou iniciar.

Exemplo de mensagens de log:

Estas mensagens aparecem aproximadamente de hora em hora:

Severe - Webhook log: Error in Webhook Processor. init WebhookProcessors failed. FS Webhook processor init failed Connecting to queue : 20839fac-4d87-4737-8df7-3c264dc8aff3_FS_Raw_Events_Queue failed. Could not create a queue with id : [20839fac-4d87-4737-8df7-3c264dc8aff3_FS_Raw_Events_Queue] Connection refused: connect.

A seguinte mensagem será postada apenas uma vez, imediatamente após a conclusão da atualização:

Severe - Failed to configure queue store. C:\Program Files\ArcGIS\DataStore\framework\runtime\rabbitmq\erl-24.2\bin\erl.ini (The system cannot find the path specified)
Note: 
This scenario does not impact Organization (portal) webhooks.

Causa

O armazenamento de filas, um componente necessário para o funcionamento dos webhooks de serviço, não foi iniciado corretamente após a atualização para a versão 11.2. O processador de webhook no ArcGIS Server falha ao se conectar e tenta se auto-reparar, registrando mensagens a cada hora.

Solução ou Solução Provisória

Se os webhooks de serviço não estiverem sendo usados ​​no ArcGIS Enterprise, o processador de webhook poderá ser desabilitado seguindo as etapas a seguir, o que evita essas mensagens de log graves.

  1. No ArcGIS Administrator Directory, navegue até Sistema. Por exemplo: 
https://server.com/webadaptor/admin/system
  1. Navegue até Propriedades. Por exemplo:
https://server.com/webadaptor/admin/system/properties
  1. Clique em Atualizar.
  2. Insira o seguinte JSON, entre chaves, { }, ou adicione este par de chaves se as propriedades do conteúdo já estiverem presentes:
{"isWebhooksEnabled":false}
  1. Reinicie o ArcGIS Server.

Se a sua organização exigir webhooks de serviço para permanecer funcional, entre em contato com o Suporte Técnico da Esri para discutir outras soluções.

ID do Artigo: 000031943

Obtenha suporte com IA

Resolva seu problema rapidamente com o chatbot de IA de suporte da Esri.

Comece a conversar agora

Informações Relacionadas

Descubra mais sobre este tema

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com Suporte Técnico

Comece a conversar agora

Ir para as opções de download