Português
Continue in the app

Patch de PostgreSQL ST_Geometry do ArcGIS Data Store 10.9

Summary

Este patch instala a versão correta do tipo espacial usado pelo armazenamento de dados relacional no Linux.

Description

Esri® anuncia o Patch de PostgreSQL ST_Geometry do ArcGIS Data Store 10.9. Este patch instala a versão correta do tipo espacial usado pelo armazenamento de dados relacional no Linux. Lida especificamente com o problema listado abaixo em Problemas corrigidos com este patch.

Nota Importante: Existe um patch opcional denominado patch de PostgreSQL ST_Geometry Patch do ArcGIS Server 10.9 que pode ser aplicado ao componente de servidor do ArcGIS Enterprise 10.9. Você precisará somente aplicar o patch a um computador e pacote de software. O arquivo ST_Geometry.SO precisará então ser movido da pasta Database Support para o servidor PostgreSQL no Linux.


Problemas Corrigidos com este patch


  • BUG-000141259 - Instalar as bibliotecas ST_Geometry do Linux da versão 10.9.0 corretas nas configurações do ArcGIS Enterprise.

Instalando este patch no Linux


Etapas da Instalação:


O ArcGIS Data Store 10.9 deve ser instalado antes de instalar este patch.

Conclua as seguintes etapas de instalação como o proprietário da pasta arcgis (também referido como o proprietário da instalação ArcGIS).

  1. Baixe o arquivo apropriado para um local diferente do local de instalação do ArcGIS.


    ArcGIS 10.9  
       
    ArcGIS Data Store ArcGIS-109-DS-PS-Patch-linux.tar
         Soma de Verificação
         (SHA256)
    66E5C752A50C8CC59EF458DA224DD9C3072936DD35C8F5C4DB518E56FBF56221

  2. Certifique-se de ter acesso à escrita no local de instalação do ArcGIS, e que ninguém esteja utilizando o ArcGIS. Aplique o patch aos armazenamentos de dados relacionais primários e auxiliares, a ordem não importa.

  3. Em cada máquina do armazenamento de dados, extraia o arquivo tar especificado digitando:

    % tar -xvf ArcGIS-109-DS-PS-Patch-linux.tar

  4. Inicie a instalação digitando:

    % ./applypatch

    Isto iniciará o diálogo do menu dirigido ao procedimento da instalação. Seleções padrões são anotadas entre parênteses ( ). Para sair do procedimento da instalação, digite 'q' a qualquer momento.

    Ao concluir o processo de configuração no armazenamento de dados primário, repita o processo para instalar e executar ./applypatch na máquina auxiliar.

  5. Para instalações do ArcGIS Data Store em uma única máquina, inicie a instalação digitando:

    % ./applypatch

    Isto iniciará o diálogo do menu dirigido ao procedimento da instalação. Seleções padrões são anotadas entre parênteses ( ). Para sair do procedimento da instalação, digite 'q' a qualquer momento.


Desinstalando este patch no Linux


A desinstalação no Linux está disponível somente na versão 10.5.1 ou superior. Estas instruções são específicas para 10.7 e posterior. Para remover esse patch, navegue até a pasta <Diretório de Instalação do Produto>/.Setup/qfe e execute o seguinte script como proprietário da Instalação do ArcGIS:


./removepatch.sh

O script removepatch.sh permite a você desinstalar patches ou pacotes de correção instalados anteriormente. Utilize a marcação -s status para obter a lista de patches ou pacotes de correção instalados, ordenados por data. Use o comando -q <QFE_ID> flag para remover patches ou pacotes de correção em ordem cronológica reversa pela data na qual foram instalados. Digite removepatch -h para ajuda de uso.

Como identificar quais produtos ArcGIS estão instalados

Para determinar quais produtos ArcGIS estão instalados, escolha a versão apropriada do utilitário PatchFinder para seu ambiente e execute-o de sua máquina local. O PatchFinder listará todos os produtos, pacotes de correção e patches instalados em sua máquina local.

Obtendo Ajuda

Sites nacionais, entre em contato com o Suporte Técnico da ESRI pelo número 1-888-377-4575, se tiver alguma dificuldade em instalar este patch. Sites internacionais, entrem em contato com o distribuidor de software local da Esri.