問題

RDP 経由でリモートで操作しているときに、エラー 126 またはエラー 87 が発生して LoadLibrary を読み込めない

Last Published: April 25, 2020

説明

ArcGIS ソフトウェアにアクセスしてリモートで作業する場合、ユーザーは、ArcGIS Desktop アプリケーションを使用するために、RDP (リモート デスクトップ プロトコル) 接続に依存します。
場合によっては、ArcMap、ArcGIS Pro、またはその他の ArcGIS ソフトウェアを起動するときに、以下のエラーが発生することがあります。

エラー: LoadLibrary がエラー 126 で失敗しました: 指定したモジュールが見つかりません。
または、
エラー: LoadLibrary がエラー 87 で失敗しました: パラメーターが正しくありません。
 
エラー メッセージの画像

原因

RDP を使用してリモート コンピューターに接続している場合、このエラーは RDP セッション自体に関連している可能性があります。 ただし、発生しているのは、RDP 接続によって指定されたビデオ カードと、リモート コンピューター上で ArcMap によって使用されているビデオ カードの競合です。 RDP は、デフォルトでは、ArcMap によって使用されているビデオ カードではなく内蔵の Intel ビデオ カードに接続します。

解決策または対処法

解決策は、Intel ビデオ カードを無効化し、RDP セッションを再起動し、ArcGIS によって使用されているコンピューター上のビデオ カードを強制的に使用させることです。

記事 ID:000023067

ArcGIS の専門家からヘルプを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動