問題

Portal for ArcGIS に調査を公開するときにデータセットが見つからない

Last Published: April 27, 2022

説明

ArcGIS Survey123 Connect または ArcGIS Survey123 から Portal for ArcGIS に調査を公開しようとすると、次のエラー メッセージが表示されます。

エラー: データセットが見つかりません。 ステータス: エラー。 詳細: コード 500
エラー: 結果パラメーターの取得中にエラーが発生しました。 ステータス: エラー。 詳細: コード 500
エラー: 新しい調査を作成できません。 エラー: データセットが見つかりません。
ArcGIS Survey123 のエラー メッセージ

原因

このエラー メッセージは、幅広い問題が存在することを意味します。 このエラーには次のような原因が考えられますが、これに限定されません。

  • Portal for ArcGIS がホスト フィーチャ レイヤーを作成できません。これは、公開における中心的な処理です。
  • PublishingTools または PublishingToolsEx ジオプロセシング サービスが実行されていないか、再起動が必要です。
  • ArcGIS Data Store ライセンスの有効期限が切れています。
  • ArcGIS Data Store が ArcGIS Server で整合チェックされていません。
  • ユーザーに、ホスト フィーチャ サービスを ArcGIS Server に公開する権限が割り当てられていません。
  • Portal for ArcGIS に公開された Survey123 フォームに、bind::esri:fieldType カスタム列が NULL に設定されたジオポイントの質問が 1 つしか含まれていません。 詳細については、BUG-000137465 をご参照ください。

解決策または対処法

  1. Portal for ArcGIS でホスト フィーチャ レイヤーを公開できることを確認します。 Portal for ArcGIS で、テンプレートを使用するか CSV ファイルを直接アップロードすることで、レイヤーを作成してお試しください。
注意: すべての調査フォームでエラーが返されない場合は、構成の問題があるか、調査の XLSForm 設計に問題がある可能性があります。 調査フォームを再公開するか、「ArcGIS Survey123: XLSForm の重要事項」で XLSForm 設計のベスト プラクティスをご確認ください。
  1. エラーが解消しない場合は、PublishingTools または PublishingToolsEx ジオプロセシング サービスのステータスを確認してください。 詳細については、「ArcGIS Server: サービスの終了と開始」をご参照ください。
  2. ArcGIS Server Manager ログを確認し、根本的な原因を特定します。 ログへのアクセス方法については、「ArcGIS Server: サーバー ログ」をご参照ください。
    1. describedatastore.bat ユーティリティを実行します。 ArcGIS Data Store コマンド ユーティリティ リファレンスの詳細については、「ArcGIS Enterprise: ArcGIS Data Store コマンド ユーティリティ リファレンス」をご参照ください。
    2. Data Store のモードとディスクの空き容量を確認します。 Data Store のモードが READONLY に設定されており、ディスクの空き容量がある場合は、次のコマンドを実行して、リレーショナル データ ストアを READWRITE に設定します。
changedatastoremode readonly|readwrite [--prompt <yes|no>]
注意: コンピューターのディスク容量が少ない場合は、データ損失を防ぐために、Data Store モードは自動的に READONLY に設定されます。
  1. Windows で ArcGIS Data Store を再起動します。
describedatastore.bat のコマンド プロンプト

記事 ID:000022129

ArcGIS の専門家からヘルプを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動