日本語

FAQ: ArcGIS Runtime SDK for Qt で TLS 1.2 を有効にするにはどうすればよいですか。

質問

ArcGIS Runtime SDK for Qt で TLS 1.2 を有効にするにはどうすればよいですか。

答え

Esri は、最新のセキュリティ プロトコルを使用することにより、ArcGIS プラットフォームで強力なセキュリティを構築して提供し、お客様のお役に立てられるよう努めています。 弊社はデータの完全性とネットワーク セキュリティを実現するために、TLS など業界最高レベルの標準を実装しようと努めています。

このような標準に対応するために ArcGIS プラットフォーム全体でソフトウェア アップデートを行い、TLS 1.2 のサポートを提供しています。 ArcGIS Online のセキュリティを向上するための取り組みの一環として、Esri では ArcGIS Online サービスに対して TLS 1.2 接続を義務付けています。 これらのサービスを引き続きご利用いただくには、対応が必要となります。

注意:
ArcGIS Runtime SDK for Qt の各リリース バージョンのサポートの状況については、Esri サポート サイトの製品ライフ サイクルのページをご参照ください。

ArcGIS Runtime SDK for Qt バージョン 10.2.6 および 100.x は、Qt Framework の最小サポート バージョン (「システム要件」に記載) 以上、または Windows、Linux、Android プラットフォーム で OpenSSL 1.0.1 以上を使用する場合に TLS 1.2 をサポートすることができます。 Qt 5.5 以降、iOS および MacOS では Apple の Secure Transport フレームワークでデフォルトで TLS 1.2 をサポートしています。

推奨要件:

  • Qt Framework の最新バージョン (ArcGIS Runtime SDK for Qt の最小サポート バージョン以上)
  • Windows、Android、Linux の OpenSSL 1.01 以降
注意:
他の Esri 製品で TLS 1.2 を使用する方法については、Esri サポートの TLS ページをご参照ください。

Related Information