日本語

FAQ: ArcGIS Runtime SDK for Java で TLS 1.2 を有効にするにはどうすればよいですか。

質問

ArcGIS Runtime SDK for Java で TLS 1.2 を有効にするにはどうすればよいですか。

答え

注意:
ArcGIS Runtime SDK for Java の各リリース バージョンのサポートの状況については、Esri サポート サイトの製品ライフ サイクルのページをご参照ください。

サポートされているすべてのプラットフォームにおいて、ArcGIS Runtime SDK バージョン 100.4 および 10.2.x は、Java 8 Update 181 以降が使用されている場合に限り、アプリケーションに変更を加えなくても TLS 1.2 を使用できます。
ただし、Java 7 環境で実行される ArcGIS 10.2.x アプリケーションで TLS を使用すると、javax.net.ssl.SSLException エラーが返されます。
Esri では、ArcGIS 10.2.x アプリケーションを Java 8 Update 181 以降で実行することをお勧めしています。

注意:
他の Esri 製品で TLS 1.2 を使用する方法については、Esri サポートの TLS ページをご参照ください。

Related Information