問題

ArcGIS Pro または ArcMap がネットワーク プリンターに印刷されない

Last Published: April 25, 2020

説明

以下の手順を実行することで、ユーザーは自身のネットワーク プリンター ドライバーを回避でき、印刷に失敗する原因がネットワーク プリンター ドライバーの設定、サポートされていないネットワーク プロトコル、またはソフトウェアのインストールの問題かどうかを判断できます。

原因

印刷の失敗には、次のような原因が考えられます。

  • ネットワーク プリンター ドライバーの設定を調整する必要がある。
  • たとえば、プリンターを WSD や XSP/ISP ではなく、標準の TCP/IP ポートに切り替える必要があります。
  • ソフトウェアのインストールに問題がある。

解決策または対処法

上記の最初の 2 つの原因について確認するには、以下の手順に従います。 これにより、クライアントはネットワーク プリンター ドライバーを回避し、印刷に失敗する原因がドライバーの設定によるものかどうかを判断できます。
Windows 10

  1. [スタート] → [コントロール パネル] → [デバイスとプリンター] の順に移動し、アイコンをクリックして [プリンターの追加] を行います。
  2. [デバイスの追加] ダイアログで、[プリンターが一覧にない場合] をクリックします。
  3. [プリンターの追加] ダイアログで、[ローカル プリンターまたはネットワーク プリンターを手動設定で追加する] を選択し、[次へ] をクリックします。
  4. [新しいポートの作成] を選択します。
  5. [ポートの種類] ドロップダウンで [標準の TCP/IP ポート] を選択し、[次へ] をクリックします。
  6. プリンターの IP アドレスを入力します。
  7. [プリンターを照会して、使用するプリンター ドライバーを自動的に選択する] をオフにします。 利用可能なオプションから適切なドライバーを選択する必要があります。 プリンターの適切なドライバーは、プリンターの製造元の Web サイトで調べることができます。 一般に、PostScript (PS) ドライバーがマップ (特に画像を含むマップ) の印刷に使用されます。 ファイルは大きくなり、プリンターに送信されるデータ量が増えるため、出力の品質は向上します。
  8. 「ローカル」プリンターのインストール プロセスを完了し、ArcMap を起動して、「新しい」デフォルト プリンターに印刷を送信します。

上記の操作が正常に実行できる場合は、まず [標準の TCP/IP ポート] が通常のプリンター設定に使用されていることを確認してください。 使用されている場合は、IT スタッフに連絡し、ネットワーク プリンター ドライバーの設定を調整します。 これは、ドライバーの設定と、現在ユーザーが印刷できるコンピューターの設定を比較することで確認できます。

上記の 3 つ目の原因については、他のアプリケーション (Microsoft Word など) が同じプリンターで印刷できるかどうかを確認してください。 他のアプリケーションがネットワーク プリンターで印刷できる場合は、ArcMap/ArcGIS Pro のプリンター設定を確認します。 設定が正しい場合は、ソフトウェアを完全にアンインストールしてから再インストールしてください。

記事 ID:000019213

ArcGIS の専門家からヘルプを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動

関連情報

このトピックについてさらに調べる