問題

コンテンツ ディレクトリにアクセスできないアイテムがあるため、webgisdr ユーティリティを使用して Portal for ArcGIS をバックアップできない

Last Published: January 1, 2021

説明

webgisdr ユーティリティを使用して Portal for ArcGIS をバックアップしようとすると、次のエラーが返されて失敗します。

エラー: { "error":{ "code":500, "details": null, "message": "サイトのエクスポートに失敗しました。 ポータルのリポジトリのエクスポートに失敗しました。 \\\\PortalDirectory\\arcgisportal\\content\\items\\" } }

原因

Portal コンテンツ ディレクトリにアイテムが存在しないため、Portal for ArcGIS はバックアップ対象の関連アイテムの場所を見つけられません。

フェデレーション環境で、フィーチャ アクセス機能を有効にしたサービスがホスト サービスとして公開されると、次の処理が行われます。

  • データがリレーショナル ArcGIS Data Store にコピーされます。
  • ホスト フィーチャ サービスがポータルのホスティング サーバーに作成されます。
  • ポータルにホスト フィーチャ レイヤー アイテムが作成されます。

ホスティング サーバーが削除されたり、アップグレード実行後に正しく構成されなかったりした場合、アイテムがコンテンツ ディレクトリに表示されてもアクセスすることはできません。 このアイテムを削除しようとするとエラーが発生し、コンテンツ ディレクトリからアイテム フォルダーを削除しても、アイテムは削除されません。 再インデックス作成しても問題は解決しません。

解決策または対処法

問題を解決するには、次の回避策を実行します。

  1. Portal for ArcGIS 管理者 URL を開きます。 URL は次のとおりです。
https://<machine_name>.<domain>.com/<webadaptorhost>/portaladmin
  1. [フェデレーション][サーバー][server_name][更新] の順に移動します。 [サーバー ロール] ドロップダウン リストから [ホスティング サーバー] を選択し、[サーバーの更新] をクリックします。
  2. [Windows サービス] を起動し、Portal for ArcGIS サービスを検索します。 サービスを右クリックして [停止] を選択します。
  3. コンテンツ フォルダーを削除した場合は、Windows ごみ箱から削除したフォルダーを復元します。
注意: 復元するコンテンツ フォルダーのないアイテムについては、同じコンテンツ アイテム ID 名の新規フォルダーを作成し、別のアイテムから任意のサブフォルダーをコピーして貼り付けます。
  1. [Windows サービス] を起動し、Portal for ArcGIS サービスを検索します。 サービスを右クリックして [開始] を選択します。
  2. Portal for ArcGIS の [コンテンツ] ページを開き、関連アイテムを削除します。 アイテムが Portal にアクセスできるようになったため、削除処理は正常に行われます。
  3. webgisdr ユーティリティを再実行し、Portal for ArcGIS のバックアップを完了します。

記事 ID:000019078

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