日本語

操作手順: シェープファイルのポリゴンをポリラインに変換

概要

さまざまなマッピングおよび分析上の理由から、ポリゴンからポリラインへの変換 (およびその逆) を行うワークフローは ArcGIS で役立ちます。 共有されているすべての境界線は 1 つのライン セグメントとなり、共有されていない境界線は別のセグメントになります。 この記事では、ポリゴンをコピーしてポリライン シェープファイルに貼り付けることによって、ポリゴンをポリラインに変換します。

注意:
ポリゴンは、[ポリゴン → ライン (Polygon To Line)] または [フィーチャ → ライン (Feature to Line)] ツールを使用してポリラインに変換できます。 これらのツールは、ArcGIS for Desktop Advanced ライセンスでのみ使用できます。

手順

ArcMap または ArcGIS Pro でポリゴンをポリラインに変換する手順は以下のとおりです。

注意:
ArcMap および ArcGIS Pro でフィーチャのコピーと貼り付けを有効にするには、ポリゴン シェープファイルおよびポリライン シェープファイルまたはフィーチャクラスを同じ場所に格納する必要があります。
ArcMap の場合:
  1. ポリゴン シェープファイルをマップに追加します。
  2. [ArcToolbox] で、[データ管理ツール][フィーチャクラス][フィーチャクラスの作成 (Create Feature Class)] の順に移動します。
  3. [フィーチャクラスの作成 (Create Feature Class)] ボックスの [フィーチャクラス ロケーション] フィールドで、ポリゴン フィーチャクラスの出力ジオデータベースまたはフォルダーを指定します。
  4. [フィーチャクラス名] に名前を設定します。
  5. [ジオメトリ タイプ][ポリライン] を選択します。
  6. [テンプレート フィーチャクラス] で、ポリゴン シェープファイルを選択します。
  7. [M 値 (メジャー値) を含む] および [Z 値を含む] フィールドには、[SAME_AS_TEMPLATE] を選択します。
  8. [座標系] で、ポリゴン シェープファイルと同じ座標系を選択して [OK] をクリックします。

    Create Feature Class dialog box

    新しいポリライン シェープファイルが作成され、[コンテンツ] ウィンドウに表示されます。
  9. 編集セッションを開始して、シェープファイルを編集します。
  10. [コンテンツ] ウィンドウでポリゴン シェープファイルを右クリックし、[属性テーブルを開く] をクリックします。
  11. 属性テーブルで、[テーブル オプション][すべて選択] の順にクリックします。

    Select all features in the attribute table
     
  12. [エディター] ツールバーの [編集ツール] を選択します。

    The Edit Tool
     
  13. マップ フレームで、選択したポリゴン フィーチャの 1 つを右クリックして [コピー] をクリックします。

    Copy all the features
     
  14. 選択したフィーチャを再び右クリックし、[貼り付け] をクリックします。
  15. [貼り付け] ダイアログ ボックスで、[ターゲット] にポリライン シェープファイルを選択し、[OK] をクリックします。

    Paste dialog box
     
  16. 編集結果を保存し、編集セッションを終了します。
  17. ポリゴン シェープファイルはポリライン シェープファイルに変換され、すべての属性が維持されます。

    Polyline shapefile is created

ArcGIS Pro の場合:
  1. [解析] タブの [ジオプロセシング] グループで [ツール] アイコンをクリックして、[ジオプロセシング] ウィンドウをアクティブにします。
  2. [ツールボックス][データ管理ツール][フィーチャクラス][フィーチャクラスの作成 (Create Feature Class)] の順に移動します。
  3. [フィーチャクラスの作成 (Create Feature Class)] ボックスの [フィーチャクラス ロケーション] フィールドで、ポリゴン フィーチャクラスの出力ジオデータベースまたはフォルダーを指定します。
  4. [フィーチャクラス名] に名前を設定します。
  5. [ジオメトリ タイプ][ポリライン] を選択します。
  6. [テンプレート フィーチャクラス] で、ポリゴン シェープファイルを選択します。
  7. [M 値 (メジャー値) を含む] および [Z 値を含む] フィールドには、[テンプレート フィーチャクラスと同じ] を選択します。
  8. [座標系] で、ドロップダウン ボックスからポリゴン シェープファイルを選択し、[実行] をクリックします。

    Create Feature Class toolbox
     
  9. 新しいポリライン シェープファイルが作成され、[コンテンツ] ウィンドウに表示されます。
  10. [コンテンツ] タブでポリゴン シェープファイルを右クリックして [属性テーブル] をクリックします。
  11. [選択] グループの属性テーブルの [表示] タブで、[すべて] をクリックしてマップ レイヤー内のすべてのフィーチャを選択します。

    In the View tab for the Table, in the Selection group, click All.
     
  12. いずれかのフィーチャを右クリックして [コピー] を選択します。 読み込みウィンドウが短時間表示されます。
  13. [編集] タブの [クリップボード] グループのドロップダウン ボックスから [貼り付け] をクリックし、[形式を選択して貼り付け] を選択します。

    Paste Special option
     
  14. [形式を選択して貼り付け] ダイアログ ボックスで、[テンプレート] を選択し、作成したポリライン シェープファイルを選択します。
  15. [ソース属性値を維持] チェックボックスをオンにして、ソース属性をポリゴン シェープファイルから転送し、[OK] をクリックします。

    Paste Special dialog box
     
  16. ポリゴン シェープファイルはポリライン シェープファイルに変換され、すべての属性が維持されます。

    Polygon shapefile is converted to polyline shapefile

関連情報