問題

説明に「AvailableFonts」としか記述されていない Severe サーバー ログ メッセージが発生する (PublishingTools サービスに関連)。

Last Published: April 25, 2020

説明

サービスを公開しようとすると、エラー「パッケージは正常に作成されましたが、公開できませんでした」が発生して失敗し、サーバー ログに SEVERE: "AvailableFonts" を含む問題が記録されます。 このメッセージは、System/PublishingTools.GPServer メッセージに関連しています。 以下の図に、ログ メッセージのサンプルを示します。

The image of the SEVERE log message.

原因

この問題は、PublishingTools サービスが参照しようとしている AvailableFonts HTML ファイルと XML ファイルが、実行中の ArcGIS Server コンピューターの PublishingTools フォルダーにないことを意味します。

ファイルの有無を確認するには、ArcGIS Server がインストールされたコンピューターで次のフォルダーを開きます。

C:\arcgisserver\directoried\arcgisoutput\System\PublishingTools_GPServer\System_PublishingTools
注意:
フォルダーには、2 つの AvailableFonts ファイルを含む 30 個ほどの HTML ファイルと XML ファイルがあります。

解決策または対処法

この問題を解決するには、AvailableFonts HTML ファイルと XML ファイルを ArcGIS Server フォルダーで置換する必要があります。 ファイルを含むフォルダーは、実行中の ArcGIS Server がインストールされた別のコンピューターからコピーできます。 フォルダーをコピーしたら、ArcGIS Server サービスを再開します。 詳細については、Web ヘルプ ドキュメント「ArcGIS Server: サービスの起動と停止」をご参照ください。

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