日本語

不具合: ドライブのディスク容量が不足すると、ArcGIS Data Store のローカル構成ファイルが破損する

説明

ArcGIS Data Store がインストールされているドライブのディスク容量が不足すると、ローカル データ ストア構成ファイルが破損する可能性があります。 結果として、リレーショナル データ ストアのバックアップが失敗するおそれがあります。

次に示す症状を評価すると、破損が発生していることがわかる場合があります。

  • Describedatastore コマンドを実行すると、出力に所有システムの URL が欠落していることが示されます。
    Owning system URL.........""   
  • Listadminusers コマンドを実行すると、Database Repl User が "dsrepuser" ではなく "repuser" として表示され、"sde" ユーザーのパスワードが "sde" であると示されます。
    Admin users for relational data store ds_abcd1234
    =================================================
    Database Admin User.... adm_32ret / tT30!bYk22jF
    Database Repl User..... repuser / repuser
    GDB Admin User......... sde / sde   
  • Listmanageduser コマンドを実行すると、ユーザーが返されません。
    Managed user for relational data store ds_abcd1234
    =======================================================
    UserName     Password       Database   
  • データ ストアのバックアップが失敗し、次のエラーが返されます。
    エラーが発生しました: ユーザーのトークンを生成できませんでした。   

原因

この問題は、既知の不具合である BUG-000105166 に関連するものであり、ArcGIS Data Store 10.5.1 で解決されています。

対処法

上記の症状は、主に ArcGIS Data Store 10.4.1 で発生しますが、破損している状態の間にデータ ストアが 10.4.1 からアップグレードされた場合は、バージョン 10.5 でも発生することがあります。

この問題が発生した場合は、バックアップが失敗し、コマンドによって上記の結果が返されます。この場合は、リレーショナル データ ストアの登録を試行しないでください。 この問題を解決する際には、Esri テクニカル サポート (米国のお客様) または Esri 販売代理店 (米国外のお客様) にお問い合わせください。

関連情報