不具合

アップグレード後に、ArcGIS Server Manager 10.5 で、一部のデータ ストアの登録に失敗し、エラー "PARENT_NOT_REGISTERED" が返される

Last Published: April 25, 2020

説明

ArcGIS Server の旧バージョンから ArcGIS Server 10.5 へのアップグレード後に、ArcGIS Server Manager がビッグ データ ファイル共有、ラスター ストア、またはクラウド ストアをデータ ストアとして登録することができず、次のエラー メッセージが返されます。

エラー:   
PARENT_NOT_REGISTERED

原因

ArcGIS Server の旧バージョンから ArcGIS Server 10.5 へのアップグレード後は、ArcGIS Enterprise 10.5 でサポートされている新しいデータ アイテム (ビッグ データ ファイル共有、ラスター ストア、クラウド ストアなど) は ArcGIS Server に登録されません。 したがって、ユーザーは、GeoAnalytics Server で使用されるビッグ データ ファイル共有や、ラスター解析サーバーで使用されるラスター ストアを登録することはできません。また、GIS リソースとデータがアマゾン ウェブ サービスまたは Microsoft Azure に格納されている場合も、ユーザーはクラウド ストアを登録できません。

対処法

ビッグ データ ファイル共有、ラスター ストア、クラウド ストアを ArcGIS Server Administrator Directory でデータ アイテムとして登録します。
  1. 管理者アカウントを使用して、ArcGIS Server Administrator Directory にログインします。
  2. [data][registerItem] の順に移動して選択します。
  3. [Item] の横のボックスで、次のコードをコピーして挿入し、クラウド ストア データ アイテムを追加します。
{
"path": "/cloudStores",
"type": "datadir"
}
  1. [Register Item] をクリックして、アイテムを ArcGIS Server に登録します。
  2. ラスター ストアとビッグ データ ファイル共有についてステップ 3 と 4 を繰り返します。
{
"path": "/rasterStores",
"type": "datadir"
}
{
"path": "/bigDataFileShares",
"type": "datadir"
}
  1. ビッグ データ ファイル共有、ラスター ストア、クラウド ストアを ArcGIS Server Manager でデータ ストアとして登録します。

記事 ID:000015216

ArcGIS の専門家からヘルプを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動

このトピックについてさらに調べる