問題

シェープファイルをパーソナル ジオデータベースにエクスポートするときにエラー 000594 または 000595 が発生する

Last Published: April 25, 2020

説明

シェープファイルをパーソナル ジオデータベースにエクスポートするときに問題が発生し、一般的なエラー Error 000594 または Error 000595 が返されます。

原因

これらの問題には原因がいくつもありますが、通常は以下のような原因です。

  • シェープファイルのサイズがパーソナル ジオデータベースに対して大きすぎる
  • シェープファイルに含まれるジオメトリが破損している
  • シェープファイルが回復不能なほど壊れている

解決策または対処法

原因に応じて、以下の回避策を使用して問題を解決します。

  • シェープファイルをパーソナル ジオデータベースにエクスポートする前に、そのシェープファイルのサイズが 2GB を超えていないことを確認します。 シェープファイルのサイズを縮小できない場合は、もっと大きな容量の別のジオデータベース タイプ (ファイル ジオデータベースやエンタープライズ ジオデータベースなど) を使用します。 パーソナル ジオデータベースは Microsoft Access データ ファイル構造 (*.mdb) を使用しており、サポートするジオデータベースのサイズは 2GB 以下に制限されています。
    注意:
    実質的に有効なサイズは 250 ~ 500MB で、それを超えるとパフォーマンスが低下してしまいます。
    さまざまなタイプのジオデータベースとサイズの比較については、「ジオデータベースの種類」をご参照ください。
  • シェープファイルをパーソナル ジオデータベースにエクスポートする前に、そのシェープファイルに破損したジオメトリがないことを確認します。 詳細については、「ジオメトリのチェックと修正」をご参照ください。
  • シェープファイルが壊れていて、「操作手順: 壊れたシェープファイルの回復」に示される方法で回復できない場合は、パーソナル ジオデータベースに新しいフィーチャクラスを作成し、[データの読み込み] ツールを使用して、シェープファイルのデータを空のフィーチャクラスに読み込みます。

記事 ID:000014197

ArcGIS の専門家からヘルプを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動