日本語

FAQ: .NET のバージョンは ArcGIS for Desktop の使用や ArcObjects での開発に影響しますか?

質問

.NET のバージョンは ArcGIS for Desktop の使用や ArcObjects での開発に影響しますか?

答え

はい。.NET のバージョンは ArcGIS for Desktop および ArcObjects のインストールに影響します。 .NET のバージョンと ArcGIS for Desktop および ArcObjects のバージョンとの間には互換性が必要です。 たとえば、ArcGIS Desktop と ArcObjects 10.0 のインストールには、最低でも .NET Framework 3.5 Service Pack 1 が必要です。 これは ArcGIS Desktop 10.1、10.2.x、10.3.x に対しても当てはまります。

ArcGIS for Desktop 10.4.x と 10.5.x には、.NET Framework バージョン 4.5 以上が必要です。 このバージョンが、もっと古い Desktop のインストール (ArcGIS for Desktop 10.0 など) もサポートできるかどうか注意してください。

ArcGIS for Desktop、ArcObjects、Engine の SDK のさまざまな 10.x リリースのシステム要件については、次の Web ヘルプ ドキュメントをご参照ください。

Related Information