日本語

操作手順: AutoCAD DWG ファイルを GIS 互換のファイル ジオデータベースに変換する

概要

以下の手順は、AutoCAD DWG ファイルを GIS 互換のファイル ジオデータベースに変換する方法を説明しています。

手順

以下のプロセスを実行する前に、CAD データの投影法を定義する必要があります。 技術情報記事「操作手順: データの空間参照、投影法、座標系を特定する」、およびこの手順に関する関連記事をご参照ください。

  1. ArcCatalog で、ファイル ジオデータベースが存在するフォルダーを右クリックして [新しいファイル ジオデータベース] に移動し、CAD フィーチャを含む新しいファイル ジオデータベースを作成します。 必要に応じてファイル ジオデータベース名を変更します。ただし、拡張子 *.gdb は保持するようにしてください。 できるだけ、ローカル ハード ドライブに新しいファイル ジオデータベースを作成することをお勧めします。
  2. ArcMap から ArcCatalog ウィンドウを開き、新しいファイル ジオデータベースを右クリックして、[デフォルト ジオデータベースに設定] を選択します。
  3. [ArcToolbox] → [変換ツール] → [ジオデータベースへ変換] の順に開き、[CAD → ジオデータベース (CAD to Geodatabase)] を選択します。
  4. ディスク上の CAD ファイルに移動し、入力として選択します。
    必要に応じて名前を変更できますが、ソフトウェアはデフォルト ジオデータベース内にフィーチャ データセットを自動的に作成してデータを格納します。 アンダースコアを使用できますが、名前にスペースを含めることはできません。
  5. CAD ファイルの [基準縮尺] を設定します。以下の手順は、データに適した基準縮尺を決定する方法を説明しています。
  6. CAD データを作成した投影法、または CAD ファイル用に作成したカスタム投影法を選択します (上記を参照)。
  7. [CAD → ジオデータベース (CAD to Geodatabase)] ダイアログで [OK] をクリックします。 CAD ファイルのフィーチャは、フィーチャ データセットのフィーチャクラスにインポートされます。
以下に、CAD アノテーションをジオデータベースにインポートする代替手順を示します。 以下の代替手順では、テキストの作成に使用されたフォント、および CAD ファイルの元のテキスト エンティティの色とサイズが保持されます。
インポートの代替手法
  1. 新しいファイル ジオデータベースを作成してジオデータベースを右クリックし、新しいフィーチャデータセットを作成して、CAD データを作成した座標系に一致するように投影法を定義します。
  2. フィーチャ データセットを右クリックし、[インポート] → [フィーチャクラス (マルチプル)] を選択して CAD ファイルを参照します。
  3. CAD ファイルをダブルクリックして開き、[ポイント][ポリライン][ポリゴン]、および [マルチパッチ] フィーチャクラスを選択します。 この手法でアノテーションをインポートすると、アノテーション文字列のアンカー ポイントにある各ポイントを含む別のポイント フィーチャクラスが作成されます。アノテーション文字列は、ジオデータベース フィーチャクラスの TextString フィールドに保存されます。
  4. [OK] をクリックします。 選択したフィーチャ タイプがジオデータベースのフィーチャ データセットにインポートされます。

CAD アノテーションをジオデータベースに変換する
この手法では、フォント、テキスト サイズ、およびテキスト色が保持されます。

  1. アノテーションに適した基準縮尺を決定するには、ArcMap で新しい空のマップを開き、CAD アノテーションを描画します。 [表示] → [データ フレーム プロパティ] の順にクリックします。 [一般] タブで、マップ単位と表示単位を、データが作成された単位 (フィート、メートルなど) に設定します。 画面表示内でアノテーションが表示または印刷に適したサイズにレンダリングされるまで、アノテーションを拡大します。 ジオデータベースの新しいアノテーション フィーチャクラスに基準縮尺が一度設定されると、変更することはできません。 プロットに使用する場合でも、画面に表示する場合でも、基準縮尺はデータに対して一般的なマップ縮尺に設定する必要があります。
  2. ArcCatalog ウィンドウを開き、CAD ファイルのポイント、ポリライン ポリゴン、およびマルチパッチ フィーチャを含むジオデータベースに移動します。
  3. フィーチャ データセットを右クリックし、[新規] → [フィーチャクラス] の順に選択します。このフィーチャクラスにはアノテーションが含まれます。
  4. 新しいアノテーション フィーチャクラスに名前を付けて、次のダイアログで [次へ] をクリックします。
  5. ArcCatalog の [新規フィーチャクラス] ダイアログ ボックスの [基準縮尺] ボックスに縮尺値を入力します。 たとえば、ArcMap の縮尺を 1: 1200 にするとします。 [基準縮尺] ボックスに「1200」と入力します。
  6. [次へ] → [次へ] の順にクリックします。
  7. 属性フィールドが表示される最後のダイアログボックスで、CAD アノテーションの属性をジオデータベース アノテーション フィーチャクラスに含める場合は、[インポート] ボタンをクリックし、CAD アノテーション フィーチャクラスに移動して選択し、[追加] をクリックします。これで、CAD アノテーションの属性がジオデータベース フィーチャクラスに追加されました。
  8. [完了] をクリックします。
  9. 新しいアノテーション フィーチャクラスを作成したら、ArcCatalog ウィンドウを閉じます。
  10. ArcMap で [カスタマイズ] →[カスタマイズ モード] の順にクリックします。 [コマンド] タブで、[カテゴリ] リストから [ラベル] を選択します。 [コマンド] リストで、[カバレッジ アノテーションの変換] ツールに注目します。 ツール アイコンを左クリックし、マウスの左ボタンを押したまま ArcMap ウィンドウに表示されているツールバーにドラッグします。 ツールがツールバーに追加されたら、[カスタマイズ] ダイアログ ボックスを閉じます。
  11. 新しい [カバレッジ アノテーションの変換] アイコンをクリックすると、ダイアログ ボックスが開き、変換するアノテーション レイヤーを選択するよう求められます。 ラジオ ボタンをクリックしてデータベースに追加し、フォルダーをクリックしてデータベース、フィーチャ データセット、およびアノテーションを追加する空のアノテーション フィーチャクラスに移動します。
  12. アノテーション フィーチャクラスへのパスが設定されたら、[変換] をクリックすると、アノテーションがジオデータベースに追加されます。
    [カバレッジ アノテーションの変換] ツールを使用する場合、同じフィーチャクラスに後でアノテーションを追加することができます。
注意: 
上記は主に CAD データをジオデータベースに変換する手法について説明していますが、ジオデータベースデータ モデルはアノテーションをサポートしているため、CAD TEXT エンティティに格納されている属性情報をデータ変換後に再作成する必要はありません。

属性が不要な場合は、ArcMap で CAD ポイント、ポリライン、ポリゴン、またはマルチパッチ フィーチャを描画し、[コンテンツ] ウィンドウ (TOC) でレイヤー名を右クリックして、[データ] → [データのエクスポート] の順に選択します。 出力データは、単純なシェープファイルおよびジオデータベース フィーチャクラスに変換できます。

CAD ファイルの特定のレイヤーまたはレベルのフィーチャのみが必要な場合は、ArcMap の [属性検索] を使用することもできます。 必要なフィーチャを選択したら、[コンテンツ] ウィンドウでレイヤー名を右クリックし、[データ] → [データのエクスポート] の順に選択します。 選択したフィーチャのみがエクスポートされます。 [シンプル データ ローダー] を使用する際は、データを属性別に並べ替えて、 ArcCatalog から既存のジオデータベース フィーチャクラスにデータを読み込むこともできます。

関連情報