日本語

操作手順: ArcMap 10.0 以前のバージョンを使用して XY データ テーブルを ArcMap にインポートし、データをシェープファイルに変換する

概要

注意:
この記事の情報は、ArcGIS バージョン 10.0 以前のバージョンにのみ適用されます。 ArcGIS のこれ以降のバージョンには異なる機能が含まれていることがあり、メニュー、コマンド、ジオプロセシング ツールの名前や場所が異なる可能性もあります。 これらのアクションを ArcGIS 10.0 以降のバージョンで実行するには、「操作手順: ArcMap 10.1 以降のバージョンで XY データを ArcMap にインポートし、データをシェープファイルまたはフィーチャクラスに変換する」をご参照ください。

ArcMap (および ArcGIS Pro) は、度分秒 (DMS) 単位のデータを読み取ることができません。そのため、そのデータをインポートする前に、10 進表記の度 (DD) に変換する必要があります。

次の手順は、Microsoft Excel を使用して XY データを 10 進表記の度単位に書式設定し、これらのデータを ArcMap でシェープファイルまたはジオデータベース フィーチャクラスに変換する方法を示しています。

ArcMap が読み取り、ポイント データをイベント テーマとして ArcMap に取り込むことができるテーブル形式は複数あります。

注意:
バージョン 9.1 以前の ArcMap が読み取ることはできる形式は、DBase III、DBase Iv、*.prn、*.txt、*.csv です。 これらが存在する場合は、Excel でこれらの形式から余分なシートを削除する必要があります。
注意:
バージョン 9.2 以降の ArcMap では、前述の形式に加えて *.xls および *.xlsx スプレッドシートを読み取ることができます。Excel の最近のバージョンでは、DBase III ファイル形式および DBase IV ファイル形式 (*.dbf) がサポートされなくなりました。

手順

  1. ArcMap がファイルからデータを正しく読み取るようにするには、Excel を使用して、経度 (X または東距) と緯度 (Y または北距) の値を含む列を桁数が 8 以上の数値に書式設定します。

    各列のコンテンツの説明は、出力ファイルに必要です。 ラベル列の ID、経度、緯度、説明などです。
下の図は、世界地図全体に経度 (X) および緯度 (Y) 座標の正数と負数の値が分布する様子を示しています。

[O-Image] Decimal degree coordinates and signs
  1. ファイルを書式設定した後、テーブル内の値が入力された行と列のすべてのセルを選択して、[ファイル] → [印刷範囲] → [印刷範囲の設定]、または [ページ レイアウト] → [印刷範囲] → [印刷範囲の設定] の順に移動します。
    • 最新バージョンの Excel では、[印刷範囲] オプションが [ページ レイアウト] タブにあります。
  2. [ファイル] → [名前を付けて保存] の順に移動して、Excel に表示される選択肢からサポートされている形式を選択します。 特定の書式設定について、このファイル形式ではサポートされないという警告が表示された場合は、[はい] をクリックします。
  3. Excel を終了します。 変更を保存するかどうかを確認するメッセージが表示されたら、[いいえ] をクリックします。
注意:
変更を保存すると、Excel がファイルを *.xls または *.xlsx ワークブックに変換しますが、これは ArcMap バージョン 9.2 以降のみで使用できます。
  1. *.dbf、*.csv、*.txt、または *.prn ファイルからデータを ArcMap に追加するには、[ツール] → [XY データの追加] の順に移動して、ファイルを選択します。
    • バージョン 10.0 では、[データの追加] ボタンをクリックします。
  2. テーブル名を右クリックして [XY データの表示] を選択します。
警告:
ArcMap バージョン 10.0 では、データ フレームの座標系が XY データに適用されます。 この座標系はデータに対して不適当である可能性があります。
[編集] ボタンをクリックして、[空間参照プロパティ] ダイアログ ボックスを表示します。 [選択] ボタンをクリックして、データの座標系を選択します。
注意:
見当たらないオブジェクト ID のフィールドが表示されているという警告が表示された場合、これは無視しても安全なメッセージなので [OK] をクリックします。 
[O-Image]

例として、GPS データはほとんどの場合、10 進表記の度単位 (つまり緯度/経度) で収集されますが、これは地理座標系です。 このディレクトリを開きます。 ほとんどの場合、GPS データは WGS 1984 測地基準系で収集されるので、World フォルダーを開いて WGS_1984.prj を選択します。

データが別の測地基準系で収集されている場合は、下部の「関連情報」セクションにある「地理座標系と使用地域」というタイトルをクリックして、適切な測地基準系を見つけます。

  1. 投影法を定義した後、[空間参照プロパティ] ダイアログ ボックスで [追加][適用][OK] をクリックします。 [XY データの追加] ダイアログ ボックスで [OK] をクリックします。 ArcMap でポイントがイベント テーマとして描画されます。 イベント テーマが ArcMap の他のデータと適合していることを確認します。
注意:
データが参照データと適合していない場合は、情報技術記事「操作手順: データの空間参照、投影法、または座標系の特定」をご参照ください。
  1. イベント テーマをシェープファイルまたはジオデータベース フィーチャクラスに変換するには、ファイル名を右クリックして [データ] → [データのエクスポート] の順に選択します。 ポイントをジオデータベース フィーチャクラスまたはシェープファイルにエクスポートできます。
  2. このプロセスの過程で、データを ArcMap データ フレームの座標系に再投影することもできます。 [表示] → [データ フレーム プロパティ][座標系] タブの順に移動して、出力データに対する目的の出力投影を選択します。 エクスポート中に投影するには、イベント テーマを右クリックして、[データ][データのエクスポート] の順に選択して、データ フレームの座標系にエクスポートするようにラジオ ボタンを変更します。 出力データは選択した出力座標系内にあります。
  3. [投影変換 (Project)] ツールを使用してイベント レイヤーを投影座標系に投影するには、次の手順に従います。
    1. ArcMap で、[ArcCatalog] → [ツールボックス] → [システム ツールボックス] → [データ管理ツール] → [投影変換と座標変換] → [投影変換 (Project)] の順に移動します。
    2. [投影変換 (Project)] ツールのダイアログ ボックスで、必須のパラメーターを入力します。
      • [入力データセット、またはフィーチャクラス]: 投影変換するフィーチャクラス、フィーチャ レイヤー、フィーチャ データセット。
      • [入力データの座標系] (オプション): 入力フィーチャクラスまたはデータセットの座標系。
      • [出力データの座標系]: 入力データの投影先となる座標系。
      • [地理座標系変換] (オプション): 2 つの地理座標系または測地基準系の間のデータ変換に使用します。
    3. [OK] をクリックします。
注意:
ArcMap にマップ内の他のデータと地理座標系が異なっているという警告が表示された場合は、[表示] → [データ フレーム プロパティ] → [座標系] タブの順に移動し、[座標変換] ボタンをクリックして、データの存在する地域に対して正しい測地基準系変換が使用されていることを確認します。
注意:
地理座標系 (測地基準系) 変換とその使用地域のリストについては、「操作手順: 測地基準系間の投影時の正しい地理座標系 (測地基準系) 変換の選択」の記事をご参照ください。 この記事の「関連情報」セクションで、コンピューターにインストールされている ArcGIS Desktop のバージョンに適合する座標変換のリストをダウンロードしてください。

関連情報