問題

ArcGIS Pro のデータを ArcGIS Online に公開できない

Last Published: November 5, 2020

説明

場合によっては、ArcGIS Pro のデータを ArcGIS Online に公開しようとすると失敗し、次のエラー メッセージが返されます。

エラー: 外部コンポーネントで例外が発生しました。
エラー: ユーザー接続を確立できません。
「外部コンポーネントで例外が発生しました」のエラー メッセージの画像。
エラー メッセージ「ユーザー接続を確立できません」の画像。

原因

この問題は、ArcGIS Pro と ArcGIS Online の間に接続が確立されていないネットワーク障害によって発生する可能性があります。

解決策または対処法

以下のいずれかの方法を選択して問題を解決してください。

ArcGIS Online へのデータの直接追加

ArcGIS Pro で使用されているのと同じ証明書を使用して ArcGIS Online にログインし、ArcGIS Online の [コンテンツ] ページにデータを追加します。

注意: ArcGIS Online アカウントがアクティブで、コンテンツを作成する権限があることを確認します。

別の場所からのデータの公開

ArcGIS Pro では、コンピューターのローカル ドライブの異なるデータセット、または別のネットワーク ロケーションに、データ レイヤーをコピーして、そのデータを公開します。 詳細については、「ArcGIS Online: ArcGIS Pro または ArcMap から公開」をご参照ください。

ArcGIS Pro の再起動

ArcGIS Pro の現在のセッションを終了し、ローカル コンピューターを再起動します。 ArcGIS Pro を開始して新しいプロジェクトを作成し、データを公開します。

ArcGIS Pro を再インストールする

ArcGIS Pro をクリーン アンインストールする手順については、「ArcGIS Pro: ArcGIS Pro のアンインストール」をご参照ください。 ArcGIS Pro の最新バージョンを再インストールして、データを ArcGIS Online に公開します。 詳細については、「ArcGIS Pro: ダウンロード、インストール、認証」をご参照ください。

記事 ID: 000023952

新しい問題や一般的な問題に対する通知とソリューションの受け取り

新しい AI チャットボットから、要約された回答とビデオソリューションを入手してください。

Esri Support アプリのダウンロード

関連情報

このトピックについてさらに調べる

ArcGIS エキスパートのサポートを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動