問題

ArcGIS Pro または ArcMap のバージョン対応データからフィーチャクラスを編集できません

Last Published: November 5, 2020

説明

ArcGIS Pro でバージョン対応データを使用してフィーチャクラスを編集すると、以下のエラー メッセージが返されます。

エラー: 移動に失敗しました。このデータは現在、別のユーザーによってロックされていて保存できません。

ArcMap で、バージョン対応データから同じフィーチャクラスを編集すると、以下のエラー メッセージが返されます。

エラー: 編集可能なレイヤーがありません。レイヤーまたはテーブルがバージョン対応登録されていません。

原因

この問題は、データセット内の一部のフィーチャクラスがバージョン対応登録されていないために起こります。通常は、新しいフィーチャクラスをフィーチャ データセットに追加したときに発生します。 「データのバージョン対応登録」をご参照ください。

バージョン対応データセットに、バージョン対応データとバージョン非対応データが混在している場合は、次の質問を検討してください。

  • なぜフィーチャクラスがバージョン非対応のデータセットにあるのかそれは新しいフィーチャクラスか 削除はできるか
  • バージョン非対応データが誤って追加されたか
  • 実際のところフィーチャクラスをバージョン対応登録する必要があるか
  • ベース テーブル移行オプションを有効にしてバージョン対応としてフィーチャクラスを登録する必要があるか これは必要に応じて検討してください。これにより、下記の「解決策」のセクションで説明するように、バージョン対応データと非バージョン対応データを登録すると問題が発生することがあります。 「データを登録する方法の決定」もご参照ください。
注意: データをバージョン対応登録できるのは、他のユーザーやアプリケーションがデータを使用していないときのみです。ADD テーブルの作成中のデータセットの変更を回避するため排他ロックが必要だからです。

解決策または対処法

この問題を解決するには、以下の手順に沿ってフィーチャ データセットをバージョン対応として再登録します。

ArcGIS Pro: [カタログ] ツリーでバージョン対応登録する

  1. [カタログ] ツリーの [プロジェクト] ウィンドウで、フィーチャ データセットを含むエンタープライズ ジオデータベースに接続します。
  2. フィーチャ データセットを右クリックし、[管理][バージョン対応登録] の順にクリックします。

    [管理] オプションおよび [バージョン対応登録] オプションを示す画像
     

ArcMap: [カタログ] ツリーでバージョン対応登録する

  1. [カタログ]ツリーで、フィーチャ データセットを含むエンタープライズ ジオデータベースに接続します。
  2. フィーチャ データセットを右クリックし、[管理][バージョン対応登録] の順にクリックします。

    バージョン対応登録オプションおよび管理オプション
     
注意: 上記の手順では、ベース テーブル移行オプションのダイアログ ボックスが表示されます。 ベース テーブルの編集を移行するオプションを使用して、または使用せずに、バージョン対応登録する方法については、「データのバージョン対応登録と登録解除のクイック ツアー」をご参照ください。
[バージョン対応登録] プロンプト
注意: データセットにバージョン対応と非対応のフィーチャクラスが混在し、ベース テーブル移行オプションが有効になっている場合、BUG-000082521 が発生する可能性があります。 フィーチャクラスがバージョン対応かどうかを判別するには、フィーチャクラスを右クリックして [プロパティ] をクリックします。 ベース テーブルの編集を移行する必要があり、バージョン対応と非対応のデータが含まれるデータセットでは、場合によっては、データセットを登録解除してからバージョン対応として再登録する必要があります。 ただし、ジオデータベースにリコンサイルされていない編集内容が含まれている場合、データ損失が発生する可能性があります。 データのバージョン対応登録を解除する前に、編集内容のリコンサイルとポスト、およびジオデータベースの完全圧縮を行う必要があります。

記事 ID: 000016850

新しい問題や一般的な問題に対する通知とソリューションの受け取り

新しい AI チャットボットから、要約された回答とビデオソリューションを入手してください。

Esri Support アプリのダウンロード

ArcGIS エキスパートのサポートを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動