問題

Microsoft Power Automate で、Survey123 Connect for ArcGIS のトリガーのドロップダウン リストに、調査が表示されない

Last Published: May 5, 2022

説明

Microsoft Power Automate を使用して、Survey123 for ArcGIS から回答が送信されるときの電子メール通知を自動化することができます。 [When a survey response is submitted] のトリガーで調査を選択しようとしたときに、ドロップダウン リストに調査が表示されない場合があります。

トリガーのドロップダウン リストを示す画像

原因

Microsoft Power Automate では、フローを保存するときに、そのフローが Webhook を調査に登録します。 Survey123 for ArcGIS で Webhook が利用されている場合、2 週間の期間の後に、ユーザーが ArcGIS Online から自動的にサイン アウトされます。

解決策または対処法

この問題を解決するには、Microsoft Power Automate から ArcGIS Online にサイン インします。

  1. Microsoft Power Automate にサイン インします。
  2. [Data][Connections] の順に移動します。
Power Automate のデータ接続ウィンドウを示す画像
  1. [Survey123] の省略 をクリックし、[アカウントの切り替え] を選択します。
[アカウントの切り替え] オプションを示す画像
  1. リダイレクトされるときに、必要な認証情報を使用して ArcGIS Online にサイン インします。
ArcGIS Online のサインイン ページの画像

ArcGIS Online にサイン インした後に、ドロップダウン リストで既存の調査を利用できます。

調査のリストを示す画像

記事 ID: 000022795

新しい問題や一般的な問題に対する通知とソリューションの受け取り

新しい AI チャットボットから、要約された回答とビデオソリューションを入手してください。

Esri Support アプリのダウンロード

関連情報

このトピックについてさらに調べる

ArcGIS エキスパートのサポートを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動