問題

ホスト フィーチャ レイヤーのカスタム ポイント シンボルが ArcGIS Online に表示されない

Last Published: January 14, 2021

説明

ArcGIS Online で、ArcMap から公開されたカスタム ポイント シンボルを含むホスト フィーチャ レイヤーを表示する場合、カスタム ポイント シンボルが表示されない、またはシンボルが単純化されて表示されます。

原因

ArcMap のカスタム スタイルの参照ファイルのシンボルは、ArcGIS Online で常にサポートされているとは限りません。 「ArcGIS Online: トラブルシューティング」によると、Web ブラウザーが複雑なカートグラフィック シンボルの一部を表示できないため、ArcGIS Online に公開するとダウングレードされるシンボルがあります。

解決策または対処法

この問題を解決するには、次の手順を実行します。

  1. ArcGIS Pro でホスト フィーチャ レイヤーを開きます。 詳細については、「ArcGIS Pro: 編集のための Web フィーチャ レイヤーの追加」をご参照ください。
  2. カスタム シンボルの *.style ファイルを、ArcGIS Pro の *.stylx ファイルにインポートします。 そのための手順については、「ArcGIS Pro: プロジェクトへのデスクトップ スタイルのインポート」をご参照ください。 インポートされた *.stylx ファイルは [カタログ] ウィンドウ → [スタイル] にリストされています。
  3. 手順 2 でインポートしたスタイル ファイルに含まれるシンボルを使用し、ポイントのシンボルを更新します。 詳細については、「ArcGIS Pro: シンボルの検索」をご参照ください。
  4. フィーチャ レイヤーを ArcGIS Online に再公開するか、上書きします。 詳細については、「ArcGIS Pro: デフォルト構成を使用した Web フィーチャ レイヤーの共有」と「ArcGIS Pro: Web フィーチャ レイヤーの上書き」をご参照ください。

記事 ID: 000024618

新しい問題や一般的な問題に対する通知とソリューションの受け取り

新しい AI チャットボットから、要約された回答とビデオソリューションを入手してください。

Esri Support アプリのダウンロード

ArcGIS エキスパートのサポートを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動