問題

ArcGIS Pro エクステンションのツールバーを使用できない

Last Published: November 25, 2020

説明

Data Interoperability や Publisher などのエクステンションを ArcGIS Pro に追加することで、アプリケーションの機能が拡張されます。 ArcGIS Pro エクステンション ライセンスが追加されると、エクステンションの機能が ArcGIS Pro のリボン タブに追加されます。 ArcGIS Pro に各エクステンションのライセンスを追加しても、エクステンションのタブが無効になっている場合があります。

原因

  • [プロジェクト] メニューの [ライセンス] タブでライセンスが有効になっていません。
  • Windows レジストリ キーの ARCPROWORKOFFLINE が True に設定されています。

解決策または対処法

次のいずれかのオプションにより、問題を解決してください。

ArcGIS Pro のエクステンションの有効化

  1. ArcGIS Pro で [プロジェクト][ライセンス] に移動します。
  2. [ライセンス オプションの構成] をクリックします。
  3. [ライセンス] ウィンドウで、必要なエクステンションをオンにして [OK] をクリックします。

ARCPROWORKOFFLINE レジストリ キーを FALSE に設定します。

警告: 下記の手順には、オペレーティング システムの重要な部分に対する変更が含まれています。 先へ進む前に、レジストリを含め、オペレーティング システムとファイルのバックアップを作成しておくことをお勧めします。 Esri では、これらの手順を実行するときに変更を誤った場合の結果について保証いたしません。 慎重に実行してください。 必要に応じて、システムの担当者に相談してください。
  1. Windows の [スタート] メニューに移動します。 [検索] バーに「regedit」と入力し、Enter キーを押します。 プロンプトが表示されたら、[ユーザー アカウント制御] ウィンドウで [はい] をクリックします。
  2. [レジストリ エディター] ウィンドウで、次のフォルダー パスに移動します。
Computer\HKEY_Current_User\Software\Esri\ArcGIS Pro\Licensing
  1. [ARCPROWORKOFFLINE] をダブルクリックして [文字列の編集] レジストリ キー ウィンドウを開きます。
  2. [値のデータ] で、値を「True」から「False」に変更します。 [OK] をクリックします。

記事 ID:000024419

ArcGIS の専門家からヘルプを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動

関連情報

このトピックについてさらに調べる