問題

ArcGIS Developer サイトで API キーを編集する際、[コンテンツとアイテム] タイルに [アイテムの追加] ボタンが表示されない

Last Published: June 2, 2021

説明

ホスト フィーチャ レイヤー、タイル レイヤー、Web マップ、GeoJSON ファイル、CSV ファイルなどのアイテムをアプリケーション プログラミング インターフェイス (API) キーに追加して、永続アクセストークンを生成してプライベート コンテンツへのアクセス権を付与できます。 API キーの編集時に [コンテンツとアイテム] タイルにアイテムを追加できます。

[API キーの編集] ページに [アイテムの追加] ボタンが表示されている [コンテンツとアイテム] タイル。
 

しかし、[アイテムの追加] ボタンがないため、アイテムを API キーに追加できません。

[API キーの編集] ページに [アイテムの追加] ボタンがない [コンテンツとアイテム] タイル。

原因

これは仕様によるものです。 [API キーの編集] ページの [コンテンツとアイテム] タイルで [アイテムの追加] ボタンを利用できるのは開発者アカウントだけです。 これは、ArcGIS Online アカウントで API キーを使用する必要がないためです。 開発者アカウントは ArcGIS Online に関連付けられておらず、主な対象は GIS 以外のユーザーです。 組織アカウントのユーザーは developers.arcgis.com サイトにアクセスできますが、開発者アカウントのユーザーがアクセスした場合とはサイトの見た目が異なります。 API キーに関連して開発者アカウントで利用できる一部の機能は組織アカウントでは利用できず、組織アカウントで利用できる機能が開発者アカウントで利用できない場合もあります。

解決策または対処法

ユーザーが ArcGIS Online 組織アカウントを保有している場合、このアカウントは API キーを使用するように設計されていないため、API キーを使用しないでください。 アカウントで利用できるアプリケーションへのアクセスにセキュリティを実装するために、OAuth2 を使用することも推奨されています。

API キーを使用するには開発者アカウントが必要です。 開発者アカウントを持っているユーザーは API キーを使用して ESRI の位置情報サービスを利用できます。 詳細については、「ArcGIS Developers: 位置情報サービス」をご参照ください。

記事 ID: 000025434

新しい問題や一般的な問題に対する通知とソリューションの受け取り

新しい AI チャットボットから、要約された回答とビデオソリューションを入手してください。

Esri Support アプリのダウンロード

関連情報

このトピックについてさらに調べる

ArcGIS エキスパートのサポートを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動