問題

ArcMap の [シンボル選択] ウィンドウにシンボルが表示されない

Last Published: November 30, 2020

説明

シンボルは、マップ上の地理フィーチャをグラフィカルに表現、分類、ランク付けするために使用されます。 ArcMap では、[シンボル選択] ウィンドウを使用してプロジェクトに適したシンボルを選択します。 マップ上のフィーチャにシンボルを適用しようとする際、[シンボル選択] ウィンドウにフォント シンボルが表示されないことがあります。

[シンボル選択] ウィンドウの画像

原因

  • 信頼されていないフォントをブロックする Windows のセキュリティ ポリシーにより、再起動後にコンピューターからフォントが削除されています。 詳細については、「Microsoft: エンタープライズ内の信頼されていないフォントのブロック」をご参照ください。
  • フォントがショートカットとしてインストールされています。
  • シンボルが使用するフォントがコンピューターにインストールされていません。 この問題は、フィーチャをあるコンピューターから別のコンピューターに転送する際に発生することがあります。

解決策または対処法

原因に応じて、次の方法のいずれかを選択し、この問題を解決してください。

ブロックされたフォントの回復

Windows がフォントを信頼できるよう、コンピューターにフォントを手動でインストールします。 手順については、「Microsoft: ブロックされたフォントのために問題が発生したアプリの修正」をご参照ください。

ショートカットとしてインストールされているフォントの検索

Microsoft: Fonts installed by using “Install as shortcut” are missing after a system restart in Windows 10 Creators Update」に記載された解決方法のいずれかで、ショートカットとしてインストールされているフォントを検索します。

フォントを、別のコンピューターから ArcMap がインストールされているコンピューターに手動でコピーします。

  1. ArcMap とフォントが正しくインストールされているコンピューターで、[コントロール パネル][フォント] の順に移動します。
  2. 必要なフォント ファイル (*.ttf) を、フォントが不足しているコンピューターの以下のディレクトリにコピーします。
C:\Windows\Fonts
  1. Fonts フォルダーで *.ttf ファイルを右クリックし、[インストール] をクリックします。
フォント ファイルのインストール オプションを示す画像
Note: 上記の方法がすべて失敗した場合は、ArcGIS Desktop で修正を実行し、不足しているフォントを再インストールします。
  1. ArcMap インストーラーを実行します。
ArcGIS Desktop のセットアップ ウィンドウの画像
  1. [修復][次へ] の順にクリックします。
  2. [インストール] をクリックします。 修復が完了したら [完了] をクリックします。 足りないフォントが Font フォルダーに追加されました。

記事 ID: 000024424

AI によるサポートを受ける

Esri サポート AI チャットボットを使用して問題を迅速に解決します。

今すぐチャットを開始

関連情報

このトピックについてさらに調べる

ArcGIS エキスパートのサポートを受ける

テクニカル サポートへのお問い合わせ

今すぐチャットを開始

ダウンロード オプションに移動