問題

スタンバイ データ ストアがプライマリ データ ストアを自動的に複製できない

Last Published: April 25, 2020

説明

ArcGIS Data Store を操作するときに、スタンバイ コンピューターはプライマリ データ ストアを自動的に複製しません。 さらに、「不完全な起動パケット」を示す通知が返されることがあります。

原因

プライマリ データ ストアとスタンバイ データ ストアの間の通信を確立することができません。 たとえば、データ ストアが、ポート 9876 を介して互いに接続を確立しようとしますが、このポートを使用できません。

この通知は、多くの場合、クライアント コンピューターがデータベース サーバーへの接続を作成したが、トラフィックを送信しない場合に返されます。 クライアント コンピューターは、定義されたポートを使用してデータベース サーバーとの接続を確立できるかどうかを断続的にチェックします。

解決策または対処法

データ ストアがホストされているサーバー サイトからスタンバイ データ ストアを削除し、スタンバイ データ ストアを再登録します。

  1. removemachine ユーティリティを使用して、スタンバイ データ ストアをサーバー サイトから削除します。 詳細については、「ArcGIS ヘルプ: removemachine」をご参照ください。
  2. スタンバイ データ ストア サービスを停止します。
    注意:
    データ ストア サービスを開始または停止するには、「ArcGIS ヘルプ: ArcGIS Data Store REST コマンド」をご参照ください。
  3. スタンバイ データ ストアの arcgisdatastore フォルダーの名前を変更します。 このフォルダーは、通常、次の場所にあります。
    C:\arcgisdatastore
    または、データ ストアのインストールに ArcGIS Enterprise Builder を使用された場合(バージョン 10.5.1 から利用可能)は、次の場所にあります。
    C:\arcgis\arcgisdatastore
  4. スタンバイ データ ストア サービスを開始します。
  5. スタンバイ データ ストア サービスをサーバーに登録します。

記事 ID: 000018651

新しい問題や一般的な問題に対する通知とソリューションの受け取り

新しい AI チャットボットから、要約された回答とビデオソリューションを入手してください。

Esri Support アプリのダウンロード

関連情報

このトピックについてさらに調べる

ArcGIS エキスパートのサポートを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動