問題

Collector for ArcGIS (Windows) が GNSS 受信機を使用してポイント フィーチャを収集できない

Last Published: April 25, 2020

説明

Collector for ArcGIS (Windows) とともに GNSS (全世界的航法衛星システム) 受信機を使用してポイント フィーチャを収集しようとすると、「位置を利用できない (Location unavailable)」または「位置を利用できない (Position not available)」ことを示すエラーが断続的に返されます。 同じポイント フィーチャを、他の ArcGIS アプリケーションおよびポイントの平均化またはライン、ポリゴンの作成などの機能とともに使用した追加テストでは、意図したとおりに動作することが示されます。

原因

この問題は、 Collector for ArcGIS (Windows) での 1 つのポイント フィーチャに特有であり、Windows オペレーティング システム (OS) の時計と Collector for ArcGIS (Windows) が同期していないことに起因して発生します。 GNSS 受信機によって記録された時間を OS によって記録された時間と比較したときに、数秒の差が検出された場合でも、エラー メッセージが返されます。

OS の時間は、オフラインで長時間作業している場合、または時計を自動的に同期させる設定が無効化されている場合に、特に不正確になる可能性があります。

注意:
Collector for ArcGIS (Android) および (iOS) は、OS の時間の代わりに、前の位置の時間を比較するため、OS の時間がアプリケーションと同期されていない場合でも、影響を受けません。

解決策または対処法

この問題を解決するには、同期するためのオプションを有効化し、Windows OS の時間を更新します。 オフラインで作業していて、同期が無効化されていない場合、Windows が時間を自動的に更新できるように、接続を再確立することをお勧めします。

同期が無効化されている場合は、次の方法を適用できます。

時間の同期を有効化して更新する
Windows の時間同期設定が無効化されている場合、この対処法を適用できます。 同期を再び有効化して時間を更新するには、次の手順を実行します。

  1. Windows の時計をクリックして、[日付と時刻の設定の変更...] を選択します。
  2. [インターネット時刻] タブをクリックします。
  3. 同期が無効化されている場合、「このコンピューターは、インターネット時刻サーバーと自動的に同期するように設定されていません」というメッセージが表示されるはずです。
  4. [設定変更...] をクリックし、[インターネット時刻サーバーと同期する] オプションをオンにします。
  5. [サーバー] ドロップダウン メニューから [time.windows.com] を選択し、[いますぐ更新する] をクリックします。
  6. [OK] をクリックします。

Windows の実行コマンドを使用する

  1. Windows で、[スタート] をクリックして「services.msc」と入力し、Enter キーを押します。
  2. Windows Time」という名前のサービスを検索します。
  3. [Windows Time] を右クリックして [プロパティ] を選択し、サービスの状態を確認します。
  4. [サービスの状態][停止] である場合、[開始] をクリックしてサービスを開始し、[OK] をクリックします。
  5. [Windows Time] サービスを右クリックして、[再起動] をクリックします。
  6. コンピューターを再起動します。

Windows コマンド プロンプトを使用する

  1. Windows の [スタート] ボタンをクリックし、[すべてのプログラム][アクセサリ] の順に移動します。 「cmd」と入力し、Enter キーを押します。
  2. [コマンド プロンプト] を右クリックして、[管理者として実行] を選択します。
  3. 次のコマンドを個別に入力し、Enter キーを押します。
    net stop w32time
    w32tm /unregister
    w32tm /register
    net start w32time
    w32tm /resync
  4. コンピューターを再起動します。
注意:
W32tm.exe が使用されて、Windows Time サービスの設定を構成します。 これを使用して、時刻サービスに伴う問題を診断することもできます。

記事 ID: 000018485

新しい問題や一般的な問題に対する通知とソリューションの受け取り

新しい AI チャットボットから、要約された回答とビデオソリューションを入手してください。

Esri Support アプリのダウンロード

関連情報

このトピックについてさらに調べる

ArcGIS エキスパートのサポートを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動