問題

Amazon S3 バケットに格納するときに、キャッシュ タイルが見つからなかった

Last Published: June 1, 2020

説明

マップ サービスおよびイメージ サービスのキャッシュを構築するときに、そのキャッシュを S3 バケットに格納できません。 キャッシュをクラウドに格納することのパフォーマンスおよび経済性は、大きいキャッシュをローカルに格納することと比較した場合、有利であることがあり、Amazon EC2 には、多種多様なニーズに対応するために、複数のインスタンス サイズおよびオプションがあります。

Amazon S3 バケットをクラウド ストアおよびキャッシュ ディレクトリとして ArcGIS Server Manager に登録した後に、S3 バケット内のストレージへのキャッシュの書き込みを開始することができます。

ただし、キャッシュされたマップまたはイメージ サービスを公開した後に、問題が生じることがあります。 キャッシュ タイルが S3 バケットに書き込まれましたが、キャッシュ タイルは、サービスを表示するときに読み込まれません。 タイルの REST エンドポイントにアクセスすると、以下の図に示すように、「404: 見つかりません」というエラーが返されます。

さらに、ArcGIS Server Manager でサービスのキャッシュ プロパティを調べると、サービスの公開時にサービス エディターで [キャッシュのタイルを使用] を指定していても、マップ サービスがデータから動的に描画されていることが示されます。

原因

この問題は、Amazon S3 バケットがクラウド ストアおよびキャッシュ ディレクトリとして ArcGIS Server Manager に登録されたときに、[S3 バケット名] フィールドまたは [フォルダー] フィールドのいずれかで「arcgiscache」というフォルダー名が指定された場合に発生します。

解決策または対処法

S3 バケットをキャッシュ ディレクトリとして ArcGIS Server Manager に登録するときに、[S3 バケット名] または [フォルダー] のフィールドで「arcgiscache」というフォルダー名を使用しないでください。別のバケットおよびフォルダー名を使用して、S3 バケットをキャッシュ ディレクトリとして再登録します。

記事 ID: 000022338

新しい問題や一般的な問題に対する通知とソリューションの受け取り

新しい AI チャットボットから、要約された回答とビデオソリューションを入手してください。

Esri Support アプリのダウンロード

関連情報

このトピックについてさらに調べる

ArcGIS エキスパートのサポートを受ける

テクニカル サポートへのお問い合わせ

Esri Support アプリのダウンロード

ダウンロード オプションに移動