PROBLÈME

ArcGIS Pro se bloque au démarrage lorsqu’il est installé avec App Layering et ajouté à Citrix XenDesktop ou XenApps

Last Published: September 15, 2020

Description

Si vous utilisez App Layering pour ajouter ArcGIS Pro à une version prise en charge de Citrix XenDesktop ou de XenApp, l’application peut ne pas démarrer si elle est exécutée par un utilisateur ne disposant pas d’un accès d’administration. Un utilisateur disposant d’un accès d’administration ne rencontre pas cet échec dans le même environnement. Dans le cas d’une installation dans XenDesktop ou XenApps sans App Layering, ArcGIS Pro ne connait pas de blocage, même exécuté par un utilisateur ne disposant pas d’autorisations élevées.

Cause

Si vous utilisez App Layering pour installer ArCGIS Pro et que vous l’ajoutez à XenDesktop ou XenApp, une autorisation supplémentaire est requise pour l’accès au service de licences FlexNet.

Solution ou alternative

Outre l’installation d’ArcGIS Pro avec App Layering, l’administrateur doit également exécuter une installation en ligne de commande du service de licences FlexNet avec le paramètre MODIFYFLEXDACL=TRUE. Par exemple :

msiexec /I "C:\Program Files\ArcGIS\Pro\Resources\ArcGIS Licensing Service\ArcGISLS.msi" MODIFYFLEXDACL=TRUE

ID d’article:000023466

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement

En savoir plus sur ce sujet