français

Problème : l’application ArcGIS Indoors iOS ne s’ouvre pas si vous sélectionnez un lien renvoyant vers une localisation partagée

Description

Lorsque vous sélectionnez un lien vers une localisation « indoor » partagée sur un appareili OS sur lequel ArcGIS Indoors est installé, la localisation s’ouvre dans l’application Web Indoors au lieu de l’application mobile.

Cause

Voici les causes possibles de ce problème :

  • L’application Web ArcGIS Indoors n’est pas déployée dans le dossier contenant par défaut les applications du portail. Pour en savoir plus, reportez-vous à la rubrique Déployer le site Web pour Indoors.
  • L’appareil iOS utilise la version 12.2.

Dans les deux cas, à la place du lancement de l’application Indoors iOS, l’application Web Indoors s’ouvre directement dans le navigateur Web défini par défaut sur l’appareil iOS.

Solution ou procédure de contournement

  1. Téléchargez le fichier iOS_AppLaunch_KB000021003.zip
  2. Procédez à la sauvegarde d’ArcGIS Enterprise.
  3. Connectez-vous à la machine Portal for ArcGIS.
  4. Arrêtez Portal for ArcGIS.
  5. Extrayez le contenu du fichier zip dans un dossier temporaire.
  6. Copiez-collez les fichiers de l’archive zip dans le dossier suivant :
\portal\apps\indoors\
Remarque :
Sélectionnez Replace (Remplacer) ou Yes (Oui) si un message s’affiche et indique qu’un fichier index.html existe déjà
  1. Démarrez Portal for ArcGIS.
  2. La page Web suivante apparaît lorsque l’utilisateur sélectionne une localisation partagée après ce changement.