PROBLÈME

l’interface de la page de connexion Portal for ArcGIS ne s’affiche pas dans Chrome

Last Published: April 25, 2020

Description

Lorsque vous utilisez le navigateur Chrome pour vous connecter à un portail ArcGIS, la section de connexion n’apparaît pas ; seul un élément web rompu est signalé.

Image of the missing element
Remarque :
Pour vérifier s’il s’agit bien de ce problème, ouvrez les outils de développement de Chrome (F12) pour examiner la console. Dans l’onglet Console, vous devez trouver une erreur indiquant que la section de l’interface ne peut pas s’afficher à cause des X-Frame-Options.

Cause

Ce problème survient lorsque la valeur de l’en-tête X-Frame-Options est réglée sur SAMEORIGIN dans Web Adaptor.

Solution ou alternative

Pour résoudre le problème, procédez comme suit sur la machine sur laquelle Web Adaptor est installé :
  1. Dans le Panneau de configuration de Windows, accédez à Outils d’administration et exécutez le Gestionnaire des services Internet (IIS).
  2. Développez la fenêtre gauche et cliquez sur le Web Adaptor du portail concerné.
  3. Dans la fenêtre droite, sous la catégorie IIS, sélectionnez l’option HTTP Response Headers (En-têtes de réponse HTTP).
  4. Double-cliquez sur l’en-tête X-Frame-Options.
  5. Remplacez les valeurs de ce champ par :
ALLOW-FROM https://portal.domain/webadaptor
  1. Cliquez sur OK.
  2. Ouvrez Chrome et rendez-vous sur la page de connexion pour vous assurer que l’élément de page de connexion est chargé.

ID d’article:000019542

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement

Informations associées

En savoir plus sur ce sujet