français

FAQ : comment activer TLS 1.2 pour ArcGIS Runtime SDK for Qt ?

Question

FAQ : comment activer TLS 1.2 pour ArcGIS Runtime SDK for Qt ?

Réponse

Esri s’est engagé à établir et assurer une sécurité renforcée sur la plateforme ArcGIS ainsi qu’à soutenir nos clients en faisant appel aux protocoles de sécurité les plus récents. Nous nous efforçons de mettre en œuvre les normes industrielles les plus élevées, notamment le protocole TLS, afin de garantir l’intégrité des données et la sécurité des réseaux.

Pour se conformer à ces normes, Esri propose des mises à jour logicielles sur la plateforme ArcGIS de manière à qu’elle prenne en charge TLS 1.2. Dans le cadre de l’amélioration de la sécurité sous ArcGIS Online, Esri réclame des connexions TLS 1.2 pour l’exécution des services ArcGIS Online. Une intervention de l’utilisateur est obligatoire afin de garantir un accès continu à ces services.

Remarque :
Reportez-vous aux pages Product Life Cycle sur le site du support technique Esri pour en savoir plus sur la prise en charge de chaque version publiée de ArcGIS Runtime SDK for Qt.

Les versions 10.2.6 et 100.x de ArcGIS Runtime SDK for Qt prennent en charge TLS 1.2 en utilisant la version Qt Framework minimale prise en charge (indiquée dans la configuration système requise) ou une version supérieure et, au moins, OpenSSL 1.0.1 ou version supérieure, sur les plateformes Windows, Linux et Android. À partir de Qt 5.5, iOS et macOS prennent en charge TLS 1.2 par défaut avec SecureTransport framework d’Apple.

Configuration requise recommandée :

  • La version la plus récente de Qt Framework (ou au moins la version minimale prise en charge par ArcGIS Runtime SDK for Qt)
  • OpenSSL 1.01 ou supérieur pour Windows, Android et Linux
Remarque :
Reportez-vous à la page Esri Support TLS pour plus d’informations sur l’utilisation de TLS 1.2 avec les autres produits Esri.

Related Information