français

FAQ : Comment activer TLS 1.2 pour ArcGIS Runtime SDK for Java ?

Question

FAQ : Comment activer TLS 1.2 pour ArcGIS Runtime SDK for Java ?

Réponse

Remarque :
Reportez-vous aux pages Product Life Cycle sur le site du support technique Esri pour en savoir plus sur la prise en charge de chaque version publiée de ArcGIS Runtime SDK for Java.

Sur toutes les plates-formes prises en charge, ArcGIS Runtime SDK 100.4 et 10.2.x prennent en charge TLS 1.2 sans modification de l’application si Java 8 mise à jour 181 ou ultérieure est utilisée.
Toutefois, les applications ArcGIS 10.2.x fonctionnant dans un environnement Java 7 renvoient des erreurs javax.net.ssl.SSLException lors de l’utilisation de TLS.
Esri recommande d’exécuter les applications ArcGIS 10.2.x avec Java 8 mise à jour 181 ou ultérieure.

Remarque :
Reportez-vous à la page Esri Support TLS pour plus d’informations sur l’utilisation de TLS 1.2 avec les autres produits Esri.

Related Information