français

Procédure : configurer Windows pour utiliser TLS 1.2 for ArcGIS Desktop

Résumé

Remarque :
Il s’agit d’une option facultative pour configurer ArcGIS Desktop dans le but d’utiliser TLS 1.2. Pour une description des autres options offertes, notamment l’option recommandée, reportez-vous à la rubrique : FAQ : Comment activer TLS 1.2 sur ArcGIS Desktop ?

Dans le cadre de l’amélioration de la sécurité sous ArcGIS Online, Esri réclame des connexions TLS 1.2 pour l’exécution des services ArcGIS Online. Une intervention de l’utilisateur est nécessaire afin de garantir l’accès à ces services.

Les méthodes ci-après expliquent comment configurer le système d’exploitation Windows pour qu’il utilise TLS 1.2. Cette opération autorise toutes les applications du système qui dépendent de Microsoft .NET Framework à utiliser TLS 1.2.

Remarque :
Esri  certifie  que la  configuration de l’environnement .NET pour activer TLS 1.2  n’entraîne  aucun  problème au niveau de ArcGIS.   Néanmoins, cela peut avoir des conséquences sur d’autres applications  .NET dont le comportement  TLS par défaut peut changer. Consultez un  spécialiste des systèmes informatiques,  si nécessaire.

Procédure

Remarque :
Après avoir configuré et testé ArcGIS Desktop afin qu’il utilise TLS 1.2, retournez à la page Esri Support TLS pour savoir comment utiliser TLS 1.2 avec les autres produits Esri.

La marche à suivre pour permettre à Windows d’utiliser TLS 1.2 varie selon la version de .NET Framework installée sur le système. Esri recommande d’utiliser .NET4, si possible.

  1. Vérifiez la version de .NET actuellement utilisée. Cette information peut être obtenue à partir du document d’aide Microsoft suivant :
    Procédure : Guide pratique pour déterminer les versions du .NET Framework installées.
  2. Si .NET4 est déjà installé, suivez les étapes suivantes pour configurer le système d’exploitation Windows de sorte qu’il utilise TLS 1.2 :
    1. Téléchargez le fichier zip : TLS_NET4.zip.
    2. Extrayez le contenu du fichier compressé et double-cliquez sur TLS_NET4.reg pour créer les clés de Registre appropriées.
    3. Testez vos connexions TLS 1.2 pour ArcGIS Online.
  3. Si .NET4 n’est pas installé sur le système, Esri recommande de l’installer :
    1. Téléchargez et installez .NET4 à partir du Centre de téléchargement Microsoft :
      Microsoft .NET Framework 4.7 (Web Installer).
    2. Suivez la procédure de la Section B ci-dessus.
  4. Si le système utilise .NET Version 3.5.1 et ne permet pas la mise à niveau vers .NET4, procédez comme suit pour activer TLS 1.2 :
    1. Installez les mises à jour Microsoft pour activer TLS 1.2. Microsoft recommande d’installer toutes les mises à jour des systèmes d’exploitation. Voir : Meilleures pratiques du protocole TLS (Transport Layer Security) avec .NET Framework : Exigences requises pour prendre en charge TLS 1.2 avec .NET Framework 3.5
      Les mises à jour TLS 1.2 suivantes sont disponibles :
    2. Téléchargez le fichier zip suivant : TLS_NET35.zip.
    3. Extrayez le fichier TLS_NET35.reg et double-cliquez dessus pour créer les clés de Registre appropriées.
    4. Testez vos connexions TLS 1.2 pour ArcGIS Online.
Remarque :
Reportez-vous aux pages Product Life Cycle sur le site du support technique Esri pour en savoir plus sur la prise en charge de chaque version ArcGIS Desktop publiée.

Informations associées