PROBLÈME

message de consignation grave pour le serveur avec pour seule description « AvailableFonts » associé au service PublishingTools

Last Published: April 25, 2020

Description

Toute tentative de publication des services échoue avec le message d’erreur « L’empaquetage a réussi, mais la publication a échoué », et le journal du serveur a enregistré le problème suivant : « SEVERE: "AvailableFonts" ». Le message est associé au message System/PublishingTools.GPServer. L’image suivante est un exemple du message de consignation.

The image of the SEVERE log message.

Cause

Le problème indique que les fichiers AvailableFonts aux formats HTML et XML auxquels la méthode PublishingTools tente de faire référence sont absents du dossier PublishingTools sur la machine ArcGIS Server.

Pour vérifier si les fichiers sont manquants, accédez au dossier suivant figurant sur la machine sur laquelle ArcGIS Server est installé :

C:\arcgisserver\directoried\arcgisoutput\System\PublishingTools_GPServer\System_PublishingTools
Remarque :
Le dossier contient environ 30 fichiers HTML et XML, notamment deux fichiers AvailableFonts.

Solution ou alternative

Pour remédier à l’erreur, il convient de placer les fichiers AvailableFonts HTML et XML dans le dossier ArcGIS Server. Le dossier qui contient les fichiers peut être copié depuis une autre machine que la machine ArcGIS Server utilisée. Une fois le dossier copié, redémarrez les services ArcGIS Server. Pour cela, reportez-vous à la rubrique d’aide sur le Web suivante, ArcGIS Server : Démarrer et arrêter des services.

ID d’article:000018401

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement

Informations associées

En savoir plus sur ce sujet