PROBLÈME

l’interrogation d’un service de carte échoue et affiche une erreur de journal du serveur

Last Published: April 25, 2020

Description

L’interrogation d’un service de carte se solde par un échec et affiche l’erreur suivante dans le journal du serveur :

Error: 
Délai d’attente dépassé.

Cause

Le problème provient de ressources insuffisantes en matière d’instance et de cœurs de traitement machine pour lancer une requête sur des services de carte étendus. Par défaut, ArcGIS Server génère davantage de traitements ArcSOC.exe dans le système d’exploitation pour gérer les requêtes sur les services de carte étendus. Ainsi, la publication de 50 services de carte dynamiques peut générer plus de 100 traitements ArcSOC.exe sur la machine. Toutefois, ArcGIS Server ne peut générer que deux instances au maximum par service de carte, ce qui limite la capacité du serveur à 100 traitements. Le manque d’instances est à l’origine de l’affichage de l’erreur et de l’échec de l’interrogation.

Solution ou alternative

En principe, le paramètre du nombre maximal d’instances équivaut à n + 1, où n désigne le nombre de cœurs sur le serveur. Si le nombre maximal d’instances est défini sur un nombre supérieur au paramètre conseillé, les utilisateurs peuvent être confrontés à des problèmes de performance étant donné que ArcGIS Server consomme des ressources supplémentaires. Cela peut mener à l’arrêt inattendu du service. Il est recommandé de mettre à niveau le processeur de la machine en fonction des capacités désirées afin d’autoriser un plus grand nombre d’instances. Il est possible de modifier le nombre maximal d’instances via ArcGIS Server Manager via un compte d’administration ou de publication.

Pour déterminer le nombre d’instances optimal dont vous avez besoin dans une configuration de service, il convient de surveiller le serveur dans la durée. Vous pouvez étudier, par exemple, la manière dont les applications utilisent les instances. Vous pouvez ajuster le nombre d’instances disponibles si les requêtes expirent ou si les temps d’attente des clients sont trop longs. Un serveur est prêt à gérer des volumes importants de requêtes même s’il vient juste d’être mis sous tension. Il peut lancer plus de 90 threads, chaque thread étant capable de gérer des requêtes simultanées. Chaque thread qui charge en mémoire maîtrise parfaitement, entre autres fonctions, la sécurité, les propriétés, les paramètres et les services de ArcGIS Server. Le nombre de threads et la mémoire augmentent lorsqu’un système est très sollicité, pour s’assurer qu’il reste très performant même s’il reçoit une charge plus importante. Il faut personnaliser avec précaution le nombre maximal d’instances et l’expiration pour veiller à ce que cela n’ait pas d’impact négatif sur les performances de la machine et les opérations. Le serveur est déjà réglé pour délivrer des performances optimales, toute modification ne doit donc être apportée qu’en cas de nécessité absolue.

L’article de la base de connaissances, Problème : le nombre d’instances ArcSOC provoque des problèmes de performances dans ArcGIS for Server, comporte des instructions sur la modification du nombre d’instances par machine.

 

ID d’article:000017615

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement

Informations associées

En savoir plus sur ce sujet