ERREUR

Connexion impossible à l’API Portaladmin après la mise à niveau vers Portal for ArcGIS 10.5.1

Last Published: April 25, 2020

Message d’erreur

Si Portal for ArcGIS est mis à niveau vers la version 10.5.1 alors qu’un serveur proxy de transfert est configuré sur la version précédente, l’utilisateur peut se connecter à l’application d’accueil Portal for ArcGIS et à l’API de partage, mais pas à l’API Portaladmin.

Cause

L’authentification de l’API Portaladmin ne peut pas s’effectuer via le serveur proxy de transfert spécifié. Lorsque vous essayez de vous connecter, une des erreurs suivantes se produit dans le navigateur web :

Erreur : 
« Invalid Token » (Jeton non valide)
ou
« You are not authorized to access this resource » (Vous n’êtes pas autorisé à accéder à cette ressource)

En outre, les journaux du portail affichent des messages du type :

Erreur :
Failed to generate a token for user 'portaladmin'. java.lang.Exception: Server returned HTTP status code 404. Requested URL: https://portaladmin.domain.com:7443/arcgis/sharing/generateToken (Echec de la génération d’un jeton pour l’utilisateur 'portaladmin'. java.lang.Exception : le serveur a renvoyé le code d’état HTTP 404. URL demandée : https://portaladmin.domain.com:7443/arcgis/sharing/generateToken)

Solution ou alternative

Avant de procéder à la mise à niveau vers Portal for ArcGIS 10.5.1, supprimez tous les paramètres JSON (JavaScript Object Notation) du proxy de transfert de Portal for ArcGIS.

  1. Connectez-vous à l’API Portaladmin avec un compte d’administrateur.
  2. Sélectionnez System (Système) > Properties (Propriétés) > Update (Mettre à jour) (https://portal.domain.com:7443/arcgis/portaladmin/system/properties/update).
  3. Supprimez toutes les références aux paramètres du proxy de transfert.
  4. Sélectionnez Update Properties (Mettre à jour les propriétés) pour enregistrer les modifications.
  5. Déconnectez-vous de Portal for ArcGIS. L’application redémarre.
  6. Une fois Portal for ArcGIS redémarré, reconnectez-vous à Portaladmin pour vérifier que les paramètres ont été enregistrés.
  7. Créez une sauvegarde à l’aide de l’utilitaire de sauvegarde ArcGIS Enterprise.
  8. Une fois la sauvegarde terminée, procédez à la mise à niveau vers Portal for ArcGIS 10.5.1.

ID d’article:000016419

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement

Informations associées

En savoir plus sur ce sujet