ERREUR

Echec du processus de partage externe

Last Published: April 25, 2020

Message d’erreur

La tentative de publication d’un fichier de formes sur ArcGIS Online via ArcGIS Pro renvoie le message d’erreur suivant.

Erreur : 
Echec du processus de partage externe
Image of the error message

Cause

Cette erreur se produit du fait de l’installation de Python avec ArcGIS Pro. A partir de la version 1.3, Python est installé avec ArcGIS Pro ; il n’est donc plus nécessaire de procéder à une deuxième installation de Python for ArcGIS Pro pour exécuter les script Python autonomes. Il arrive que plusieurs versions de Python d’environnements différents (32 bits ou 64 bits) soient installées sur le même ordinateur. La variable d’environnement PYTHONPATH remplace la variable PATH, chargée de désigner la version Python à utiliser. Pour plus d’informations, voir FAQ: Why do Python scripts fail on a machine with both ArcGIS for Server and Desktop installed? (FAQ : Pourquoi les scripts Python échouent sur une machine sur laquelle ArcGIS for Server et ArcGIS for Destop sont installés ?)

Remarque :
Avant la version 1.3 d’ArcGIS Pro, Python pouvait être installé en tant que programme indépendant. 

Solution ou alternative

Selon l’origine du problème, sélectionnez l’une des options suivantes pour y remédier.

Avertissement : 
Les instructions ci-après impliquent de modifier des parties essentielles de votre système d’exploitation. Il est recommandé de sauvegarder votre système d’exploitation et vos fichiers, y compris le Registre, avant de continuer. Consultez un spécialiste des systèmes informatiques, si nécessaire. 

Esri ne garantit pas les résultats obtenus en cas de modifications non conformes aux consignes. Par conséquent, soyez prudent et continuez à vos propres risques.
  • Définir la variable d’environnement Python PATH

    Cette solution peut être appliquée sans désinstaller ArcGIS Pro.

    1. Dans Windows, cliquez sur Démarrer > cliquez avec le bouton droit sur Ordinateur > Propriétés > Paramètres système avancés > Variables d’environnement.
    2. Dans la fenêtre Variables d’environnement, recherchez PYTHON ou PYTHONPATH sous l’onglet Variables système.
    3. Supprimez les variables PYTHON et PYTHONPATH. Cette action a pour effet de supprimer la variable d’environnement Python PATH.
    Remarque :
    Supprimer les deux variables peut perturber la fonctionnalité de Python dans ArcMap, mais pas dans ArcGIS Pro.
    
  • Lancer ArcGIS Pro via un script de commandes

    Au cas où vous ne parveniez pas à supprimer les variables système en raison d’une dépendance d’application active sur la même machine qu’ArcGIS Pro, lancez ArcGIS Pro à l’aide d’un fichier de commandes en respectant la syntaxe suivante :

    SET PYTHONPATH="" START "" "C:\Program Files\ArcGIS\Pro\bin\ArcGISPro.exe"
    
  • Publier directement sur ArcGIS Online
    1. Compressez le fichier de formes à l’aide d’un logiciel de compression de fichiers tel que WinZip.
    2. Connectez-vous à www.arcgis.com.
    3. Accédez à My Content (Mon contenu).
    4. Cliquez sur Add Item (Ajouter un élément) > From my computer (A partir de mon ordinateur).
    5. Sélectionnez le fichier de formes compressé et ajoutez un nom et les étiquettes nécessaires. Cliquez sur Add Item (Ajouter un élément).
  • Désinstaller et réinstaller ArcGIS Pro

    Si les solutions suggérées ci-dessus ne donnent aucun résultat, procédez à la désinstallation et à la réinstallation d’ArcGIS Pro. Cela est recommandé si la suppression de la variable d’environnement Python PATH ne permet pas de résoudre l’erreur.

    1. Désinstallez ArcGIS Pro à partir du Panneau de configuration Windows. Pour savoir comment faire, reportez-vous à Aide d’ArcGIS : Désinstallation d’ArcGIS Pro.
      Remarque :
      Si la procédure de désinstallation échoue, arrêtez tous les processus ArcGIS Pro actifs via le Gestionnaire de tâches avant de recommencer. 
      
    2. Une fois ArcGIS Pro désinstallé, supprimez les fichiers ArcGIS Pro restants qui figurent, en règle générale, aux emplacements suivants :
      C:\Users\\AppData\Local\ESRI\ArcGISPro 
      (et tout autre dossier Pro)
      C:\Users\\AppData\Roaming\ESRI\ArcGISPro
      C:\Program Files\ArcGIS\Pro
      C:\ProgramData\Microsoft\Windows\StartMenu\Programs\ArcGIS\ArcGIS Pro
      Remarque :
      Il est possible que certains dossiers soient cachés. Pour les rendre visibles, reportez-vous à Aide de Windows : Afficher les fichiers cachés.
    3. Recherchez et supprimez les clés de registre suivantes :
      HKEY_CURRENT_USER\Software\ESRI\ArcGIS Online For Pro
      HKEY_CURRENT_USER\Software\ESRI\ArcGISPro
      HKEY_CURRENT_USER\Software\ESRI\ArcGISPro1.0
      Avertissement :
      Esri ne prend pas en charge les modifications apportées au Registre du système d’exploitation.
      
    4. Redémarrez la machine et réinstallez ArcGIS Pro.

ID d’article:000015162

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement

Informations associées

En savoir plus sur ce sujet