PROBLÈME

la suppression d’une version de géodatabase renvoie l’erreur « Etat cible introuvable dans la table ETAT »

Last Published: April 25, 2020

Description

Lorsque vous essayez de supprimer une version de la géodatabase, le message d’erreur générique suivant est renvoyé :

Erreur : 
Etat cible introuvable dans la table ETAT.

Cause

Ce problème survient lorsque les tables de deltas de la géodatabase sont corrompues.

Solution ou alternative

Esri propose des outils de géotraitement qui permettent d’identifier les incohérences au sein des tables système de versionnement d’une géodatabase versionnée, comme décrit ci-après.

Remarque :
Avant d’exécuter un outil de réparation, assurez-vous que l’utilisateur est connecté en tant qu’administrateur de géodatabase. Seul un administrateur de géodatabase détient les privilèges nécessaires à l’exécution des outils de réparation.
  1. Exécutez l’outil Diagnose Version Tables (Diagnostiquer des tables de version) pour vérifier la présence d’éventuelles incohérences dans les tables de géodatabase.
    1. Dans Catalog (Catalogue), accédez à System Toolboxes (Boîtes à outils système) > Data Management Tools (Outils de gestion des données) > Geodatabase Administration (Administration de géodatabase) > Diagnose Version Tables (Diagnostiquer des tables de version).
    2. Dans la fenêtre Diagnose Version Tables (Diagnostiquer des tables de version) , indiquez la connexion à la base de données en entrée souhaitée ainsi que l’emplacement du journal de diagnostic des tables de version, puis cliquez sur OK.
  2. Exécutez l’outil Repair Version Tables (Réparer des tables de version) pour résoudre les éventuelles incohérences identifiées à l’étape 1.
    1. Dans Catalog (Catalogue), accédez à System Toolboxes (Boîtes à outils système) > Data Management Tools (Outils de gestion des données) > Geodatabase Administration (Administration de géodatabase) > Repair Version Tables (Réparer des tables de version).
    2. Dans la fenêtre Repair Versions Tables (Réparer des tables de version), indiquez la connexion à la base de données en entrée souhaitée ainsi que l’emplacement du journal de réparation des tables de version, puis cliquez sur OK.
  3. Exécutez l’outil Diagnose Version Metadata (Diagnostiquer des métadonnées de version) afin d’identifier d’éventuelles incohérences au sein des tables système de versionnement d’une géodatabase versionnée.
    1. Dans Catalog (Catalogue), accédez à System Toolboxes (Boîtes à outils système) > Data Management Tools (Outils de gestion des données) > Geodatabase Administration (Administration de géodatabase) > Diagnose Version Metadata (Diagnostiquer des métadonnées de version).
    2. Dans la fenêtre Diagnose Version Metadata (Diagnostiquer des métadonnées de version), indiquez la connexion à la base de données en entrée souhaitée ainsi que l’emplacement en sortie du fichier journal des métadonnées, puis cliquez sur OK.
  4. S’il existe des incohérences dans les tables système de versionnement de la géodatabase versionnée, exécutez l’outil Repair Version Metadata (Réparer des métadonnées de version).
    1. Dans Catalog (Catalogue), accédez à System Toolboxes (Boîtes à outils système) > Data Management Tools (Outils de gestion des données) > Geodatabase Administration (Administration de géodatabase) > Repair Version Metadata (Réparer des métadonnées de version).
    2. Dans la fenêtre Repair Version Metadata (Réparer des métadonnées de version), indiquez la connexion à la base de données en entrée souhaitée ainsi que la sortie du fichier journal, puis cliquez sur OK.

ID d’article:000013519

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