ERREUR

code d’erreur 0x800F0906 activant .NET 3.5 sous Windows 8

Last Published: April 25, 2020

Message d’erreur

Il arrive que certains utilisateurs ne soient pas en mesure d’activer la fonction .NET 3.5 sous Windows 8 (configuration nécessaire lors de l’installation d’ArcGIS for Desktop 10.1). L’erreur suivante s’affiche :

« Windows n’a pas pu effectuer les modifications demandées. Windows n’a pas pu se connecter à Internet pour télécharger les fichiers nécessaires. Vérifiez que vous êtes connecté à Internet, puis cliquez sur "Réessayer" pour recommencer. Code d’erreur: 0x800F0906 »

Essayer d’installer .NET 3.5 sous Windows 8

1. Accédez à la fenêtre Ajouter des fonctionnalités Windows : depuis la page de démarrage de Windows, cliquez avec le bouton droit sur un espace ouvert et cliquez sur « Toutes les applications ». Accédez au Panneau de configuration et choisissez « Programmes et fonctionnalités ». Choisissez « Activer ou désactiver des fonctionnalités Windows » dans la fenêtre Programmes et fonctionnalités.

2. Activez la fonctionnalité .NET Framework 3.5 : l’option « .NET Framework 3.5 (inclut .NET 2.0 et 3.0) » n’est pas sélectionnée. Cliquez sur la case en regard de « .NET Framework 3.5 (inclut .NET 2.0 et 3.0) », puis cliquez sur OK.

3. Essayez d’ajouter la fonctionnalité à partir de Windows Update : Fonctionnalités de Windows recherche les fichiers requis. Lorsque vous avez la possibilité de le faire, choisissez « Télécharger des fichiers à partir de Windows Update », Fonctionnalités de Windows indique qu’il télécharge les fichiers requis.

4. Windows affiche l’erreur :

« Windows n’a pas pu effectuer les modifications demandées. Windows n’a pas pu se connecter à Internet pour télécharger les fichiers nécessaires. Vérifiez que vous êtes connecté à Internet, puis cliquez sur "Réessayer" pour recommencer. Code d’erreur: 0x800F0906 »

Après avoir cliqué sur OK, la boîte de dialogue suivante s’affiche :

« Une erreur s’est produite. Certaines fonctionnalités n’ont pas été modifiées correctement. »

Cause

Windows 8 ne parvient pas à se connecter aux serveurs Windows pour télécharger et installer le contenu .NET 3.5.

Solution ou alternative

Cette solution nécessite que l’utilisateur possède un DVD Windows 8.

  1. Insérez le disque d’installation de Windows 8 et notez le nom du lecteur. Vérifiez les dossiers /source/sxs.
  2. Exécutez une invite de commande en tant qu’administrateur.

    a) Dans la page de démarrage de Windows, cliquez avec le bouton droit sur un espace ouvert et cliquez sur « Toutes les applications ».
    b) Recherchez l’invite de commande, cliquez avec le bouton droit sur l’application et choisissez « Exécuter en tant qu’administrateur ».
    c) Si l’invite Contrôle de compte d’utilisateur apparaît, choisissez Oui.
  3. Utilisez l’outil de gestion et de maintenance des images de déploiement (DISM) pour installer .NET 3.5.

    Tapez la commande suivante dans la fenêtre d’invite de commande et appuyez sur Entrée :

    Code :
    Dism /online /enable-feature /featurename:NetFx3 /All /Source:« Chemin d’accès au support d’installation »:\sources\sxs /LimitAccess


    Si, par exemple, le « Chemin d’accès au support d’installation » correspond au lecteur D:, le code est le suivant :

    Code :
    Dism /online /enable-feature /featurename:NetFx3 /All /Source:D:\sources\sxs /LimitAccess

ID d’article:000011777

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement

En savoir plus sur ce sujet