français

Problème : statut du serveur de licences : NOT RUNNING pour ArcGIS License Manager 10.x

Description

Statut du serveur de licences : NOT RUNNING pour ArcGIS License Manager 10.x

Cause

Vous risquez d’obtenir le statut NOT RUNNING (pas en cours d’exécution) à l’issue de l’installation du logiciel ArcGIS License Manager 10.x ou après l’avoir exécuté. Ce problème peut être imputable aux pare-feux, aux antivirus, aux programmes de blocage des courriers indésirables (anti-spam), aux affectations de ports ou à leur disponibilité, à des variables d’environnement, à des données résiduelles provenant d’installations antérieures ou encore à la présence d’anciens fichiers license.dat.

Solution ou procédure de contournement

Pour résoudre ce problème, il peut être nécessaire d’effectuer une ou plusieurs des étapes suivantes.

Avant d’essayer les solutions suggérées ci-après, examinez les messages d’erreur consignés, le cas échéant, dans le fichier journal de débogage. Ce fichier est disponible depuis License Server Administrator > Diagnostics ou sous \ArcGIS\License10.x\bin\lmgrd9.log.

  • Désactivez le pare-feu. La section Informations associées ci-dessous explique comment configurer le gestionnaire de licences (ArcGIS License Manager) à cet effet. Vous devrez, pour ce faire, modifier le contenu du fichier service.txt.
  • Désactivez la protection antivirus.
  • Exécutez la commande Netstat –a pour savoir quelles connexions TCP actives sont ouvertes et en cours d’exécution sur un hôte connecté en réseau. Cette commande répertorie les protocoles actifs, l’adresse locale et le numéro de port, l’adresse de destination, le numéro de port et l’état de la connexion. Elle permet, en outre, d’identifier les ports du gestionnaire de licences (dans la plage 27000-27009) en cours d’utilisation par d’autres processus.

    Exécutez l’instruction suivante à partir d’une invite de commande. L’opérateur -a correspond à l’option Tout.

    netstat -a

  • Assurez-vous que le démon LMGRD peut être exécuté manuellement à partir de la ligne de commande.

    Accédez au chemin de répertoire approprié (basé sur le système d’exploitation), puis exécutez la commande permettant de lancer manuellement le service ArcGIS License Manager :

    C:\> cd 'C:\Program Files\arcgis\license10.1\bin'
    C:\> cd 'C:\Program Files (x86)\arcgis\license10.1\bin'

    Lancez manuellement le service ArcGIS License Manager :

    C:\> lmgrd.exe -c service.txt

    Si le service démarre, le problème provient probablement du Registre Windows ou des variables d’environnement. Pour résoudre les problèmes relatifs aux variables d’environnement, reportez-vous à l’étape suivante.

  • Vérifiez si des variables d’environnement ont été configurées :

    1) Cliquez sur Démarrer > Panneau de configuration > Système.
    2) Dans le panneau Système, cliquez sur Paramètres système avancés.
    3 ) Dans la boîte de dialogue Propriétés système, sélectionnez l’onglet Paramètres système avancés.
    4) Sélectionnez le bouton Variables d’environnement.
    5) Dans la fenêtre Variables d’environnement, parcourez les variables système et notez celles qui sont configurées pour ArcGIS License Manager, telles que « ARCGIS », « ESRI » ou « LM » ou toute autre variable qui y ressemble provenant d’Esri ou de Flexera.
    6) Sélectionnez la variable et cliquez sur le bouton Supprimer pour éliminer les variables inutiles.

  • Vérifiez s’il reste des données provenant d’une installation antérieure d’ArcGIS License Manager :

    A partir du dossier d’installation du logiciel, selon le système d’exploitation :

    C:\Program Files\ArcGIS
    C:\Program Files (86)\ArcGIS
    C:\Program Files\Common Files\ESRI
    C:\Program Files (86)\Common Files\ESRI
    C:\Documents and Settings\\Application Data\ESRI\
    C:\Users\\AppData\Roaming\ESRI\

    Dans le Registre Windows, selon le système d’exploitation :

    HKEY_LOCAL_MACHINE > Software > ESRI
    HKEY_LOCAL_MACHINE > Software > WOW6432Node > ESRI
    HKEY_LOCAL_MACHINE > Software > Microsoft > Windows > CurrentVersion > Uninstall --> vérifiez les clés de Registre
    HKEY_CURRENT_USER > Software > ESRI
    HKEY_CURRENT_USER > Software > WOW6432Node > ESRI
    HKEY_CLASSES_ROOT > Installer > Products --> vérifiez les clés de Registre

  • Exécutez l’outil de surveillance des processus (Process Monitor ou ProcMon) :

    Téléchargez l’outil ProcMon à partir de la page Windows Sysinternals.

    1) Cliquez sur le lien Download Process Monitor (Télécharger Process Monitor).
    2) Sélectionnez Ouvrir.
    3) Double-cliquez sur ProcMon.exe et sélectionnez Exécuter.
    4) Sélectionnez J’accepte pour accepter les termes de la licence.
    5) Dans le menu Filter (Filtre), select Filter (Filtrer).
    6) Sous Display entries matching these conditions (Afficher les entrées répondant à ces conditions), sélectionnez les critères suivants dans les deux premières listes déroulantes : « Process Name » (Nom du processus), « contains » (contient) et saisissez arcgis.exe. Dans la troisième liste déroulante, sélectionnez le critère « Include » (Inclure), puis cliquez sur le bouton Add (Ajouter).
    [O-Image] Process Monitor

    7) Cliquez sur Apply (Appliquer), puis sur OK.
    8) Installez ArcGIS License Manager 10.1.
    9) Une fois l’installation terminée et après vous être assuré que le statut de License Server Administrator est « NOT RUNNING », enregistrez le fichier journal sous ProcMon ; sélectionnez File (Fichier) > Capture Events (Capturer les événements) (Ctrl+E) pour décocher cette option afin d’arrêter le suivi des événements.
    10) Depuis l’outil ProcMon installé sur l’ordinateur, sélectionnez File (Fichier) > Save (Enregistrer) (Ctrl+S) pour enregistrer le suivi des événements dans un fichier « .pml ».
    Enregistrement du fichier journal

    [O-Image]
  • Supprimez le stockage approuvé :

    Remarque :
    Commencez par annuler l’autorisation du logiciel, si cela est possible.

    Procédez comme suit pour supprimer le stockage approuvé :

    1) Arrêtez le service ArcGIS License Manager.
    2) Accédez au dossier FLEXnet figurant dans le chemin du système d’exploitation approprié :

    Windows XP et 2003 Server
    C:\Documents and Settings\All Users\Application Data\FLEXnet

    Windows Vista, 7 et Server 2008
    C:\ProgramData\FlexNet

    Unix/Linux
    /usr/local/share/macrovision/storage

    3) Supprimez le fichier ArcGIS_xxxxxxxx_tsf.data ou supprimez l’intégralité des fichiers ArcGIS au sein du dossier FlexNet.
    4) Lancez les services ArcGIS License Manager.

Informations associées