français

Erreur : Valeurs de pixels non valides

Message d'erreur

Lorsque vous exportez aux formats de fichier PDF, AI, EMF, JPEG, TIFF, PNG et autres à partir d’ArcMap, le message d’erreur suivant est renvoyé :

Erreur :
« Valeurs de pixels non valides »

Cause

L’imprimante installée par défaut sur l’ordinateur ne fournit pas les bonnes informations à ArcMap.

ArcMap utilise les informations de l’imprimante installée par défaut sur l’ordinateur pour définir la résolution de l’affichage dans ArcMap, ce qui affecte à son tour la résolution des fichiers d’exportation. L’imprimante installée précédemment par défaut sur l’ordinateur comportait des informations de résolution non valides ou incompréhensibles de telle sorte qu’ArcMap n’est pas en mesure d’exporter correctement la carte.

Cette erreur est également renvoyée lorsque l’option « Clip Output to Graphics Extent » (Découper suivant l’emprise de l’élément graphique) est cochée dans la boîte de dialogue Export Map (Exporter la carte).

Solution ou procédure de contournement

  1. En mode Mise en page, cliquez sur File (Fichier) > Export (Exporter).
  2. Décochez l’option Clip Output to Graphics Extent (Découper suivant l’emprise de l’élément graphique).
  3. Exportez la carte.
Si le problème persiste, utilisez l’une des options suivantes :
  • Installez une imprimante « fictive » et définissez-la comme l’imprimante par défaut. Reportez-vous au lien figurant dans la section Informations associées ci-dessous pour en savoir plus sur l’imprimante fictive recommandée par Esri et la procédure d’installation.
  • Réinstallez l’imprimante par défaut sur l’ordinateur.
  • Si une autre imprimante installée est disponible, définissez-la comme l’imprimante par défaut.

Informations associées

Dernière modification: 9/21/2020

ID d’article: 000008983

Logiciel: ArcGIS for Desktop Advanced 10.3, 10.2.2, 10.2.1, 10.2, 10.1 ArcGIS for Desktop Basic 10.3, 10.2.2, 10.2.1, 10.2, 10.1 ArcGIS for Desktop Standard 10.3, 10.2.2, 10.2.1, 10.2, 10.1 ArcGIS-ArcEditor 9.3.1, 9.3, 9.2, 9.1, 9.0, 10 ArcGIS-ArcInfo 9.3.1, 9.3, 9.2, 9.1, 9.0, 10 ArcGIS-ArcView 9.3.1, 9.3, 9.2, 9.1, 9.0, 10 ArcMap 10.8.1, 10.8, 10.7.1, 10.7, 10.6.1, 10.6, 10.5.1, 10.5, 10.4.1, 10.4, 10.3.1, 10.3, 10.2.2, 10.2.1, 10.2, 10.1, 10