français

Procédure : importer un fichier d’échange ArcInfo (E00) dans ArcGIS

Résumé

Les instructions fournies expliquent comment importer un fichier d’échange ArcInfo, .e00, dans une couverture ou une grille.

Lire les informations importantes suivantes avant de continuer :

• Le fichier E00 en entrée ne peut pas être placé dans un répertoire dont le nom ou le chemin d’accès comprend un espace.
• La couverture ou la grille en sortie ne peut pas être écrite dans un répertoire dont le nom ou le chemin d’accès comprend un espace.
• La couverture ou la grille en sortie ne peut pas comporter plus de 13 caractères, ni contenir d’espaces (les traits de soulignement sont autorisés) ou de caractères spéciaux. Par exemple, #, @, %.
• Le nom de la couverture peut être identique à celui du fichier E00 d’origine, mais ce n’est pas une obligation.
• Le nom de la couverture ne porte pas d’extension. Par exemple, si le fichier E00 se nomme « parcels.e00 », la couverture en sortie peut se nommer « parcels » sans extension.
• Le nom de la couverture en sortie est en minuscules.
• Dans ArcGIS 9.2 et versions antérieures, les noms des dossiers dans le chemin d’accès à l’entrée ou à la sortie ne peuvent pas dépasser 8 caractères. Dans ArcGIS 9.3 ou version ultérieure, cette restriction ne s’applique plus.

Avertissement :
Si le fichier E00 est compressé et extrait avec WinZip, consultez le lien de la section Informations associées ci-dessous pour savoir comment corriger WinZip et éviter l’endommagement des données au cours du processus d’extraction.

Procédure

  • ArcGIS 10.x - Toutes les licences ArcGIS
    1. Ouvrez ArcMap.
    2. Cliquez sur l’icône ArcToolbox.
    [O-Image] ArcToolbox icon for ArcGIS 10.x

    3. Dans ArcToolbox, développez Conversion Tools (Outils de conversion).
    4. Développez « To Coverage » (Vers la couverture).
    5. Double-cliquez sur « Import from E00 » (Importer depuis E00).
    6. Dans la zone de saisie « Input interchange file » (Fichier d’échange en entrée) (fichier E00), cliquez sur Browse (Parcourir). Accédez au répertoire souhaité et sélectionnez le fichier. Attribuez un nom au jeu de données en sortie.

    Remarque :
    Les restrictions concernant les noms de fichiers énoncées au début de cet article s’appliquent également à ArcGIS 10.x.

    7. Cliquez sur OK. Une boîte de dialogue indiquant la fin du processus apparaît. Cliquez sur Fermer.
    8. Cliquez sur « Add Data » (Ajouter des données)
    [O-Image] ArcMap Add Data button for Desktop 10.x
    et accédez au répertoire sélectionné.

  • ArcGIS 9.x - Toutes les licences ArcGIS
    1. Lancez ArcCatalog.
    2. Accédez à Tools (Outils) > Customize (Personnaliser) > onglet Toolbars (Barres d’outils).
    3. Cochez la case correspondant à la barre d’outils ArcView 8.x Tools (Outils ArcView 8.x) et cliquez sur Close (Fermer).
    4. Ancrez la barre d’outils Conversion Tools (Outils de conversion) dans ArcCatalog.
    5. Cliquez sur le menu déroulant Conversion Tools (Outils de conversion).
    6. Sélectionnez « Import from Interchange File » (Importer depuis un fichier d’échange).
    7. Pour Input file (Fichier en entrée), accédez à l’emplacement du répertoire du fichier E00 à importer et sélectionnez le fichier E00.
    8. Spécifiez un nom et un emplacement pour le jeu de données en sortie.
    [O-Image] Import .e00
    Remarque :
    Un traitement par lots permet d’importer plusieurs fichiers. Cliquez sur le menu déroulant Batch (Par lot). Pour ajouter d’autres fichiers E00 à traiter, cliquez sur le bouton Add Row (Ajouter une ligne).
    [O-Image] Add Row
    A. Sélectionnez ou saisissez le nom du nouveau fichier en entrée.
    B. Saisissez le nom du nouveau jeu de données en sortie.
    C. Répétez cette procédure comme il convient pour importer d’autres fichiers E00 dans le même traitement par lots.
    D. Une fois tous les fichiers E00 ajoutés pour le traitement par lots, cliquez sur OK.

  • ArcGIS 9.x - ArcInfo UNIQUEMENT
    Avertissement :
    Cet outil fonctionne uniquement si ArcInfo Workstation est également installé sur l’ordinateur.

    1. Accédez à ArcToolbox > Coverage Tools (Outils de conversion) > To Coverage (Vers la couverture) > Import from Interchange File (Importer depuis un fichier d’échange).

    Consultez le lien de la section Informations associées ci-dessous si les outils de couverture sont absents d’ArcToolbox.
  • Si ArcInfo Workstation est installé sur l’ordinateur, utilisez la commande IMPORT (IMPORTER) sur la ligne de commande ArcInfo pour effectuer cette opération.

    Code :
    Arc : import .e00


    Remarque :
    Pour savoir si ArcInfo Workstation est installé sur l’ordinateur, accédez à Démarrer > Programmes > ArcGIS. Si l’élément « ArcInfo Workstation » n’apparaît pas dans la liste, le logiciel doit être installé pour utiliser cette méthode d’importation.

  • ArcGIS 8.x - Toutes les licences ArcGIS
    1. Ouvrez ArcToolbox.
    2. Ouvrez Conversion Tools (Outils de conversion).
    3. Ouvrez Import to Coverage (Importer vers couverture).
    4. Double-cliquez sur « ArcView Import from Interchange File » (Importation ArcView depuis un fichier d’échange).
    5. Pour le fichier en entrée, accédez à l’emplacement du répertoire du fichier E00 à importer et sélectionnez le fichier E00.
    6. Spécifiez un nom et un emplacement pour le jeu de données en sortie.
    [O-Image] Import .e00
    Remarque :
    Un traitement par lots permet d’importer plusieurs fichiers. Cliquez sur le bouton Batch (Par lot). Pour ajouter d’autres fichiers E00 à traiter, cliquez sur le bouton Add Row (Ajouter une ligne).
    [O-Image] Add Row
    A. Sélectionnez ou saisissez le nom du nouveau fichier en entrée.
    B. Sélectionnez ou saisissez le nom du nouveau jeu de données en sortie.
    C. Répétez cette procédure comme il convient pour importer d’autres fichiers E00 dans le même traitement par lots.
    D. Une fois tous les fichiers E00 ajoutés pour le traitement par lots, cliquez sur OK.

Informations associées